summaryrefslogtreecommitdiff
path: root/dh_clean
diff options
context:
space:
mode:
authorJoey Hess <joey@kodama.kitenet.net>2008-04-23 22:49:22 -0400
committerJoey Hess <joey@kodama.kitenet.net>2008-04-23 22:49:22 -0400
commit4f8a46b36e961d1a64d466a63f3a7ef6c90bafe2 (patch)
tree5bbb9dde41b2c9d87c7b544e7e3adeded0b7863d /dh_clean
parent28f84cd5c972f683506bee5f201cd93a2c09ee56 (diff)
dh_prep: New program, does the same as dh_clean -k (which will be deprecated later).
Diffstat (limited to 'dh_clean')
-rwxr-xr-xdh_clean15
1 files changed, 8 insertions, 7 deletions
diff --git a/dh_clean b/dh_clean
index a08b0b36..78e43c36 100755
--- a/dh_clean
+++ b/dh_clean
@@ -33,13 +33,8 @@ The debian/clean file can list other files to be removed.
=item B<-k>, B<--keep>
-Do not delete debian/files, or files listed in debian/clean. When do you
-want to use this? Anytime you have a debian/rules that has 2 binary targets
-that build different .deb packages; for example, one target is binary-arch,
-and the other is binary-indep, or one target builds the shared library, and
-the other the -dev package. If you didn't use -k in these cases, then
-debian/files would be deleted in the middle, and your changes file will
-only contain the last binary package that was built.
+This causes L<dh_prep(1)> to be run instead of dh_clean, for backwards
+compatibility.
=item B<-d>, B<--dirs-only>
@@ -61,6 +56,12 @@ Delete these files too.
=cut
init();
+inhibit_log();
+
+if ($dh{K_FLAG}) {
+ # dh_prep will be emulated (mostly) by the code below.
+ # TODO deprecation warning
+}
foreach my $package (@{$dh{DOPACKAGES}}) {
my $tmp=tmpdir($package);