summaryrefslogtreecommitdiff
path: root/dh_clean
diff options
context:
space:
mode:
authorJoey Hess <joey@kodama.kitenet.net>2008-07-08 13:51:02 -0400
committerJoey Hess <joey@kodama.kitenet.net>2008-07-08 13:51:02 -0400
commit2b71b515b540da977d6cdf2c0f5995d5934ac005 (patch)
tree17cdb3a536348a7670259d6f5635762ee222a25e /dh_clean
parente8324ce00e7f5fe6c1a4485203ae43db484e5b48 (diff)
dh_clean: Do not delete *-stamp files in -k mode in v7. Closes: #489918
Diffstat (limited to 'dh_clean')
-rwxr-xr-xdh_clean5
1 files changed, 2 insertions, 3 deletions
diff --git a/dh_clean b/dh_clean
index c7465d39..5fd7f936 100755
--- a/dh_clean
+++ b/dh_clean
@@ -36,8 +36,7 @@ clean target in debian/rules.
=item B<-k>, B<--keep>
-This causes L<dh_prep(1)> to be run instead of dh_clean, for backwards
-compatibility.
+This is deprecated, use L<dh_prep(1)> instead.
=item B<-d>, B<--dirs-only>
@@ -122,7 +121,7 @@ if (! $dh{D_FLAG}) {
doit('rm', '-rf', 'debian/tmp') if -x 'debian/tmp' && ! compat(1) &&
! excludefile("debian/tmp");
-if (!compat(6)) {
+if (!compat(6) && !$dh{K_FLAG}) {
complex_doit('rm -f *-stamp');
}