summaryrefslogtreecommitdiff
path: root/dh_gconf
diff options
context:
space:
mode:
authorJosselin Mouette <joss@debian.org>2010-04-10 12:36:31 +0200
committerJoey Hess <joey@gnu.kitenet.net>2010-04-10 13:19:11 -0400
commite54c44ed5f97d2b9e709b4c76bfa5767a8ac6bc1 (patch)
treef26c2bf36aa6a940e14951d28cf1d13874b61082 /dh_gconf
parentaa1d0983eebb3113ef0f0b91f3e0295a6d657928 (diff)
Remove autoscripts for GConf
Starting from 2.28.1-2, the gconf2 package uses triggers which make the maintainer scripts obsolete.
Diffstat (limited to 'dh_gconf')
-rwxr-xr-xdh_gconf11
1 files changed, 3 insertions, 8 deletions
diff --git a/dh_gconf b/dh_gconf
index 514aae7..bf9f398 100755
--- a/dh_gconf
+++ b/dh_gconf
@@ -72,17 +72,14 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
if ($mandatory ne '') {
doit("mkdir","-p","$tmp/usr/share/gconf/mandatory");
doit("install","-p","-m644",$mandatory,"$tmp/usr/share/gconf/mandatory/${priority}_$package");
- autoscript($package,"postinst","postinst-gconf-defaults","s%#OPT#%--mandatory%");
- addsubstvar($package, "misc:Depends", "gconf2 (>= 2.24.0-5)");
+ addsubstvar($package, "misc:Depends", "gconf2 (>= 2.28.1-2)");
$gconf_dep = 1;
}
my $defaults = pkgfile($package,"gconf-defaults");
if ($defaults ne '') {
doit("mkdir","-p","$tmp/usr/share/gconf/defaults");
doit("install","-p","-m644",$defaults,"$tmp/usr/share/gconf/defaults/${priority}_$package");
- autoscript($package,"postinst","postinst-gconf-defaults","s%#OPT#%%");
- autoscript($package,"postrm","postrm-gconf-defaults","s%#OPT#%%");
- addsubstvar($package, "misc:Depends", "gconf2 (>= 2.12.1-1)") unless $gconf_dep;
+ addsubstvar($package, "misc:Depends", "gconf2 (>= 2.28.1-2)") unless $gconf_dep;
$gconf_dep = 1;
}
@@ -100,9 +97,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# Get a list of the schemas
my $schemas = `find $new_schemas_dir -type f -name \\*.schemas -printf '%P '`;
if ($schemas ne '') {
- autoscript($package,"postinst","postinst-gconf","s%#SCHEMAS#%$schemas%");
- autoscript($package,"prerm","prerm-gconf","s%#SCHEMAS#%$schemas%");
- addsubstvar($package, "misc:Depends", "gconf2 (>= 2.10.1-2)") unless $gconf_dep;
+ addsubstvar($package, "misc:Depends", "gconf2 (>= 2.28.1-2)") unless $gconf_dep;
}
}
}