summaryrefslogtreecommitdiff
path: root/dh_gencontrol
diff options
context:
space:
mode:
authorjoey <joey>2002-06-20 01:31:47 +0000
committerjoey <joey>2002-06-20 01:31:47 +0000
commit3c36c2532c3907f0a315d9010654176e8e9fc319 (patch)
tree70b62139d1778f1d91e390401f5c7499c0ff622e /dh_gencontrol
parent89e2b47d7d18354a701733b401e613ed84acd8ee (diff)
r532: * Added --mainpackage= option, of use in some kernel modules packages.
* dh_gencontrol only needs to pass -p to dpkg-gencontrol if there is more than one package in debian/control. This makes it a bit more flexible in some cases.
Diffstat (limited to 'dh_gencontrol')
-rwxr-xr-xdh_gencontrol8
1 files changed, 6 insertions, 2 deletions
diff --git a/dh_gencontrol b/dh_gencontrol
index fcb91845..941c9a8c 100755
--- a/dh_gencontrol
+++ b/dh_gencontrol
@@ -53,8 +53,12 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
# Generate and install control file.
- doit("dpkg-gencontrol","-l$changelog","-isp","-p$package",
- "-Tdebian/${ext}substvars", "-P$tmp",@{$dh{U_PARAMS}});
+ my @command="dpkg-gencontrol";
+ if (GetPackages() > 1) {
+ push @command, "-p$package";
+ }
+ doit(@command, "-l$changelog", "-isp", "-Tdebian/${ext}substvars",
+ "-P$tmp",@{$dh{U_PARAMS}});
# This chmod is only necessary if the user sets the umask to
# something odd.