summaryrefslogtreecommitdiff
path: root/dh_gencontrol
diff options
context:
space:
mode:
authorjoey <joey>2001-01-25 02:04:03 +0000
committerjoey <joey>2001-01-25 02:04:03 +0000
commit8da1a397c64f933ae536be136aaab99f6105ab71 (patch)
tree6f571ebc1f37fce9e0040bd2c1394f48d78d3b2e /dh_gencontrol
parentf4f52f07ec3f5cebdd6d3bc6893f7025bad4d68f (diff)
r410: * Added the ability to make debhelper read a different file than
debian/control as the control file. This is very useful for various and sundry things, all Evil, most involving kernel packages.
Diffstat (limited to 'dh_gencontrol')
-rwxr-xr-xdh_gencontrol5
1 files changed, 3 insertions, 2 deletions
diff --git a/dh_gencontrol b/dh_gencontrol
index 15e08203..0c03dfce 100755
--- a/dh_gencontrol
+++ b/dh_gencontrol
@@ -19,8 +19,9 @@ foreach $PACKAGE (@{$dh{DOPACKAGES}}) {
}
# Generate and install control file.
- doit("dpkg-gencontrol","-l$changelog","-isp","-p$PACKAGE",
- "-Tdebian/${EXT}substvars","-P$TMP",@{$dh{U_PARAMS}});
+ doit("dpkg-gencontrol","-c".Debian::Debhelper::Dh_Lib::getcontrol(),
+ "-l$changelog","-isp","-p$PACKAGE","-Tdebian/${EXT}substvars",
+ "-P$TMP",@{$dh{U_PARAMS}});
# This chmod is only necessary if the user sets the umask to something odd.
doit("chmod","644","$TMP/DEBIAN/control");