summaryrefslogtreecommitdiff
path: root/dh_installchangelogs
diff options
context:
space:
mode:
authorjoey <joey>2003-07-04 05:00:49 +0000
committerjoey <joey>2003-07-04 05:00:49 +0000
commit8627252ea4d68d0d09381324662a071c358f6066 (patch)
tree902dd46f00bd4166b6cf855969173e0d0c8a278a /dh_installchangelogs
parent22c796dbc9758902b6a95f1a7ed5a2a4c9e869d9 (diff)
r594: * dh_installchangelogs: Install debian/NEWS as NEWS.Debian, even for native
packages. This doesn't follow the lead of the changelog for native packages for the reasons discussed in bug #192089
Diffstat (limited to 'dh_installchangelogs')
-rwxr-xr-xdh_installchangelogs10
1 files changed, 4 insertions, 6 deletions
diff --git a/dh_installchangelogs b/dh_installchangelogs
index 4c211e55..66a02558 100755
--- a/dh_installchangelogs
+++ b/dh_installchangelogs
@@ -26,10 +26,9 @@ files named debian/package.changelog exist, they will be used in preference
to debian/changelog.)
Parallelling the debian changelog handling, this program also takes care of
-debian NEWS files. If there is a debian/NEWS file, it is installed as
-usr/share/doc/package/NEWS for native packages, and as
-usr/share/doc/package/NEWS.Debian for non-native packages. debian/package.NEWS
-files can also be used.
+NEWS.Debian files. If there is a debian/NEWS file, it is installed as
+usr/share/doc/package/NEWS.Debian. debian/package.NEWS files can also be
+used.
If an upstream changelog file is specified as an option, and the package is
not a native debian package, then this upstream changelog will be installed
@@ -73,11 +72,10 @@ if (isnative($dh{MAINPACKAGE}) && defined $upstream) {
}
my $changelog_name="changelog.Debian";
-my $news_name="NEWS.Debian";
if (isnative($dh{MAINPACKAGE})) {
$changelog_name='changelog';
- $news_name='NEWS';
}
+my $news_name="NEWS.Debian";
foreach my $package (@{$dh{DOPACKAGES}}) {
my $tmp=tmpdir($package);