summaryrefslogtreecommitdiff
path: root/dh_installchangelogs
diff options
context:
space:
mode:
authorjoey <joey>2003-12-02 21:19:10 +0000
committerjoey <joey>2003-12-02 21:19:10 +0000
commite96ca35789dc7749bf5a29f1b7736f9e5877f6a4 (patch)
treec9fccc11f47fb5cc15e71b046fdb7435f9b9910d /dh_installchangelogs
parentfcaa5bcc7d65104c782634bdeb1de05d86f0662a (diff)
r1629: * Removed the no upstream changelog for debian packages test.
Even though it has personally saved me many times, debhelper is not intended to check packages for mistakes, and apparently it makes sense for some "native" packages to have a non-Debian changelog. Closes: #216099 * If a native package has an upstream changelog, call the debian/changelog changelog.Debian. * postinst-menu-method: always chmod menu-method executable even if update-menus is not. Closes: #220576 * dh_installmenu: do not ship menu-methods executable.
Diffstat (limited to 'dh_installchangelogs')
-rwxr-xr-xdh_installchangelogs24
1 files changed, 7 insertions, 17 deletions
diff --git a/dh_installchangelogs b/dh_installchangelogs
index 66a02558..7de170aa 100755
--- a/dh_installchangelogs
+++ b/dh_installchangelogs
@@ -30,13 +30,12 @@ NEWS.Debian files. If there is a debian/NEWS file, it is installed as
usr/share/doc/package/NEWS.Debian. debian/package.NEWS files can also be
used.
-If an upstream changelog file is specified as an option, and the package is
-not a native debian package, then this upstream changelog will be installed
-as usr/share/doc/package/changelog in the package build directory. If the
-changelog is a html file (determined by file extension), it will be
-installed as usr/share/doc/package/changelog.html instead, and will be
-converted to plain text with html2text to generate
-usr/share/doc/package/changelog.
+If an upstream changelog file is specified as an option, then this upstream
+changelog will be installed as usr/share/doc/package/changelog in the
+package build directory. If the changelog is a html file (determined by
+file extension), it will be installed as
+usr/share/doc/package/changelog.html instead, and will be converted to
+plain text with html2text to generate usr/share/doc/package/changelog.
=head1 OPTIONS
@@ -56,23 +55,14 @@ Install this file as the upstream changelog.
=back
-=head1 NOTES
-
-It is an error to specify an upstream changelog file for a debian native
-package.
-
=cut
init();
my $upstream=shift;
-if (isnative($dh{MAINPACKAGE}) && defined $upstream) {
- error("Cannot specify an upstream changelog for a native debian package.");
-}
-
my $changelog_name="changelog.Debian";
-if (isnative($dh{MAINPACKAGE})) {
+if (isnative($dh{MAINPACKAGE}) && ! defined $upstream) {
$changelog_name='changelog';
}
my $news_name="NEWS.Debian";