summaryrefslogtreecommitdiff
path: root/dh_installdeb
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2010-11-02 16:24:04 -0400
committerJoey Hess <joey@kitenet.net>2010-11-02 16:24:04 -0400
commit4c8f8cd25e912508731e3494d3ee303bccf0001e (patch)
tree28eb1a4ce85f1ecd39a7e86295fb892d41b01fec /dh_installdeb
parenta9116a731fb4baf4873e5693681c3602bbeee6a3 (diff)
maintscript files
dh_installdeb: Support debian/package.maintscript files, which can contain dpkg-maintscript-helper commands. This can be used to automate moving or removing conffiles, or anything added to dpkg-maintscript-helper later on. Closes: #574443 (Thanks, Colin Watson)
Diffstat (limited to 'dh_installdeb')
-rwxr-xr-xdh_installdeb36
1 files changed, 36 insertions, 0 deletions
diff --git a/dh_installdeb b/dh_installdeb
index 35c9016..8cfb4b7 100755
--- a/dh_installdeb
+++ b/dh_installdeb
@@ -50,12 +50,32 @@ In v3 compatibility mode and higher, all files in the etc/ directory in a
package will automatically be flagged as conffiles by this program, so
there is no need to list them manually here.
+=item I<package>.maintscript
+
+Lines in this file correspond to L<dpkg-maintscript-helper(1)> commands and
+parameters. Any shell metacharacters will be escaped, so arbitrary shell
+code cannot be inserted here. For example, a line such as C<mv_conffile
+/etc/oldconffile /etc/newconffile> will insert maintainer script snippets
+into all maintainer scripts sufficient to move that conffile.
+
+A versioned Pre-Dependency on dpkg is needed to use
+L<dpkg-maintscript-helper(1)>. An appropriate Pre-Dependency is
+set in ${misc:Pre-Depends} ; you should make sure to put that token into
+an appropriate place in your debian/contorl file.
+
=back
=cut
init();
+# dpkg-maintscript-helper commands with their associated dpkg pre-dependency
+# versions.
+my %maintscript_predeps = (
+ "rm_conffile" => "1.15.7.2",
+ "mv_conffile" => "1.15.7.2",
+);
+
foreach my $package (@{$dh{DOPACKAGES}}) {
my $tmp=tmpdir($package);
@@ -76,6 +96,22 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
next;
}
+ my $maintscriptfile=pkgfile($package, "maintscript");
+ if ($maintscriptfile) {
+ foreach my $line (filedoublearray($maintscriptfile)) {
+ my $cmd=$line->[0];
+ error("unknown dpkg-maintscript-helper command: $cmd")
+ unless exists $maintscript_predeps{$cmd};
+ addsubstvar($package, "misc:Pre-Depends", "dpkg",
+ ">= $maintscript_predeps{$cmd}");
+ my $params=escape_shell(@$line);
+ foreach my $script (qw{postinst preinst prerm postrm}) {
+ autoscript($package, $script, "maintscript-helper",
+ "s!#PARAMS#!$params!g");
+ }
+ }
+ }
+
# Install debian scripts.
foreach my $script (qw{postinst preinst prerm postrm}) {
debhelper_script_subst($package, $script);