summaryrefslogtreecommitdiff
path: root/dh_installdeb
diff options
context:
space:
mode:
authorjoey <joey>2001-11-17 21:01:33 +0000
committerjoey <joey>2001-11-17 21:01:33 +0000
commit2d76f9e8cf76146e7b24ac4232918f584cfb8a16 (patch)
tree0d68cc6e0a8f3be71b0f3e45d4c5177a564fa189 /dh_installdeb
parentda77014a9f5c7467c47e527e70a7fb8c433595c7 (diff)
r495: * dh_undocumented: check for existing uncompressed man pages. Closes: #87972
* Optimized dh_installdeb conffile finding. Closes: #119035 * dh_installdeb: changed the #!/bin/sh -e to set -e on a new line. Whether this additional bloat is worth it to make it easier for people to sh -x a script by hand is debatable either way, I guess. Closes: #119046 * Added a check for duplicated package stanzas in debian/control, Closes: #118805
Diffstat (limited to 'dh_installdeb')
-rwxr-xr-xdh_installdeb4
1 files changed, 2 insertions, 2 deletions
diff --git a/dh_installdeb b/dh_installdeb
index a97fc009..1b363a9f 100755
--- a/dh_installdeb
+++ b/dh_installdeb
@@ -75,7 +75,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# Auto-generate script header and add .debhelper
# content to it.
if (-f "debian/$ext$file.debhelper") {
- complex_doit("echo '#!/bin/sh -e' > $tmp/DEBIAN/$file");
+ complex_doit("printf '#!/bin/sh\nset -e\n' > $tmp/DEBIAN/$file");
complex_doit("cat debian/$ext$file.debhelper >> $tmp/DEBIAN/$file");
doit("chown","0.0","$tmp/DEBIAN/$file");
doit("chmod",755,"$tmp/DEBIAN/$file");
@@ -94,7 +94,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# Automatic conffiles registration: If it is in /etc, it is a
# conffile.
if (! compat(2) && -d "$tmp/etc") {
- complex_doit("find $tmp/etc -type f |sed 's~^$tmp~~' >> $tmp/DEBIAN/conffiles");
+ complex_doit("find $tmp/etc -type f -printf '/etc/%P\n' >> $tmp/DEBIAN/conffiles");
# Anything found?
if (-z "$tmp/DEBIAN/conffiles") {
doit("rm", "-f", "$tmp/DEBIAN/conffiles");