summaryrefslogtreecommitdiff
path: root/dh_installdebconf
diff options
context:
space:
mode:
authorjoey <joey>2004-02-09 05:24:40 +0000
committerjoey <joey>2004-02-09 05:24:40 +0000
commit4f162e192c3563d740490cc99ced1513104ac34c (patch)
treeb521746cbacfde4afc5af4031b767d1f87101a83 /dh_installdebconf
parentad3f34f9653fe848816f2af915b9cdd260fc4421 (diff)
r1655: * Added udeb support, as pioneered by di-packages-build. Understands
"XC-Package-Type: udeb" in debian/control. See debhelper(1) for details. * Dh_Lib: add and export is_udeb and udeb_filename * dh_builddeb: name udebs with proper extension * dh_gencontrol: pass -n and filename to dpkg-gencontrol * dh_installdocs, dh_makeshlibs, dh_md5sums, dh_installchangelogs, dh_installexamples, dh_installman, dh_installmanpages: skip udebs * dh_shlibdeps: skip udebs. This may be temporary. * dh_installdeb: do not process conffiles, shlibs, preinsts, postrms, or prerms for udebs. Do not substiture #DEBHELPER# tokens in postinst scripts for udebs. * dh_installdebconf: skip config script for udebs, still do templates
Diffstat (limited to 'dh_installdebconf')
-rwxr-xr-xdh_installdebconf2
1 files changed, 1 insertions, 1 deletions
diff --git a/dh_installdebconf b/dh_installdebconf
index 66dafd0c..ebf6a131 100755
--- a/dh_installdebconf
+++ b/dh_installdebconf
@@ -83,7 +83,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
doit("install","-o",0,"-g",0,"-d","$tmp/DEBIAN");
}
- if ($config ne '') {
+ if (! is_udeb($package) && $config ne '') {
doit("install", "-o", 0, "-g", 0, "-m", 755, "-p",
$config, "$tmp/DEBIAN/config");
}