summaryrefslogtreecommitdiff
path: root/dh_installdirs
diff options
context:
space:
mode:
authorjoey <joey>2001-02-09 10:36:35 +0000
committerjoey <joey>2001-02-09 10:36:35 +0000
commit066f9dda63f48950863310a8e507adb397ae7e5a (patch)
treefc2b6563da5c6fa112d0d6988c9b5e6a2de751af /dh_installdirs
parent4ef7ac85194b43fa4efcbab831744dfbed3a400b (diff)
r430: the great pod juggernaught rolls on through the night
Diffstat (limited to 'dh_installdirs')
-rwxr-xr-xdh_installdirs60
1 files changed, 58 insertions, 2 deletions
diff --git a/dh_installdirs b/dh_installdirs
index 340c966e..e0aae209 100755
--- a/dh_installdirs
+++ b/dh_installdirs
@@ -1,9 +1,52 @@
#!/usr/bin/perl -w
-#
-# Reads debian/dirs, creates the directories listed there
+
+=head1 NAME
+
+dh_installdirs - create subdirectories in package build directories
+
+=cut
use strict;
use Debian::Debhelper::Dh_Lib;
+
+=head1 SYNOPSIS
+
+ dh_installdirs [debhelper options] [-A] [dir ...]
+
+=head1 DESCRIPTION
+
+dh_installdirs is a debhelper program that is responsible for creating
+subdirectories in package build directories.
+
+Any directory names specified as parameters will be created in the package
+build directory of the first package dh_installdirs is told to act on. By
+default, this is the first binary package in debian/control, but if you use
+-p, -i, or -a flags, it will be the first package specified by those flags.
+
+A file named debian/package.dirs can list other directories to be created.
+Separate the directory names with whitespace.
+
+Be sure to only use directory names relative to the package build
+directory. Ie, "/usr/bin" should not be used, use "usr/bin" instead.
+
+=head1 OPTIONS
+
+=over 4
+
+=item B<-A>, B<--all>
+
+Create any directories specified by command line parameters in ALL packages
+acted on, not just the first.
+
+=item I<dir ...>
+
+Create these directories in the package build directory of the first
+package acted on. (Or in all packages if -A is specified.)
+
+=back
+
+=cut
+
init();
foreach my $package (@{$dh{DOPACKAGES}}) {
@@ -40,3 +83,16 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
doit("install","-d",@dirs);
}
}
+
+=head1 SEE ALSO
+
+L<debhelper(1)>
+
+This program is a part of debhelper.
+
+=head1 AUTHOR
+
+Joey Hess <joeyh@debian.org>
+
+=cut
+