summaryrefslogtreecommitdiff
path: root/dh_installmanpages
diff options
context:
space:
mode:
authorjoey <joey>2004-02-09 05:24:40 +0000
committerjoey <joey>2004-02-09 05:24:40 +0000
commit4f162e192c3563d740490cc99ced1513104ac34c (patch)
treeb521746cbacfde4afc5af4031b767d1f87101a83 /dh_installmanpages
parentad3f34f9653fe848816f2af915b9cdd260fc4421 (diff)
r1655: * Added udeb support, as pioneered by di-packages-build. Understands
"XC-Package-Type: udeb" in debian/control. See debhelper(1) for details. * Dh_Lib: add and export is_udeb and udeb_filename * dh_builddeb: name udebs with proper extension * dh_gencontrol: pass -n and filename to dpkg-gencontrol * dh_installdocs, dh_makeshlibs, dh_md5sums, dh_installchangelogs, dh_installexamples, dh_installman, dh_installmanpages: skip udebs * dh_shlibdeps: skip udebs. This may be temporary. * dh_installdeb: do not process conffiles, shlibs, preinsts, postrms, or prerms for udebs. Do not substiture #DEBHELPER# tokens in postinst scripts for udebs. * dh_installdebconf: skip config script for udebs, still do templates
Diffstat (limited to 'dh_installmanpages')
-rwxr-xr-xdh_installmanpages4
1 files changed, 3 insertions, 1 deletions
diff --git a/dh_installmanpages b/dh_installmanpages
index 39946f6a..415c86b7 100755
--- a/dh_installmanpages
+++ b/dh_installmanpages
@@ -126,11 +126,13 @@ sub find_so_man {
}
foreach my $package (@{$dh{DOPACKAGES}}) {
+ next if is_udeb($package);
+
my $tmp=tmpdir($package);
# Find all filenames that look like man pages.
@manpages=();
- @allpackages=GetPackages('');
+ @allpackages=getpackages('');
find(\&find_man,'.'); # populates @manpages
foreach my $page (@manpages) {