summaryrefslogtreecommitdiff
path: root/dh_perl
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-08-17 16:02:15 -0400
committerJoey Hess <joey@gnu.kitenet.net>2009-08-17 16:02:15 -0400
commite62c63b901834e4d98d9ee93aa32f9ae6ec0b3da (patch)
tree750cdb881f47435e0737c7461285c09d9931cfc6 /dh_perl
parent5e3b38634b5b0a24b30d59b13ac7164dc613afb0 (diff)
dh_perl: Remove perl minimum dependency per new policy. Closes: #541811
Diffstat (limited to 'dh_perl')
-rwxr-xr-xdh_perl11
1 files changed, 2 insertions, 9 deletions
diff --git a/dh_perl b/dh_perl
index fbeee2d..56d9f21 100755
--- a/dh_perl
+++ b/dh_perl
@@ -60,9 +60,9 @@ directories by default.
=head1 CONFORMS TO
-Debian policy, version 3.0.1
+Debian policy, version 3.8.3
-Perl policy, version 1.18
+Perl policy, version 1.20
=cut
@@ -71,10 +71,6 @@ init();
my $vendorlib = substr $Config{vendorlib}, 1;
my $vendorarch = substr $Config{vendorarch}, 1;
-# the installation dir for arch-indep modules changed to
-# /usr/share/perl5 in this version:
-my $min_version = '5.6.0-16';
-
# Cleaning the paths given on the command line
foreach (@ARGV) {
s#/$##;
@@ -125,9 +121,6 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
unless $version;
$version = ">= $version";
}
- elsif ($deps & PM_MODULE) {
- $version = ">= $min_version";
- }
# no need to depend on an un-versioned perl-base -- it's
# essential