summaryrefslogtreecommitdiff
path: root/dh_python
diff options
context:
space:
mode:
authorjoeyh <joeyh>2006-10-03 17:04:27 +0000
committerjoeyh <joeyh>2006-10-03 17:04:27 +0000
commitd171e01587a6dcad4663f0892325523bba7663db (patch)
treefc36e380b337fc76485bf88cf62651027baaca45 /dh_python
parent73e5366969d286a6385688e3e85b6de213627478 (diff)
r1946: * dh_python: Also be a no-op if there's a Python-Version control file field.
Diffstat (limited to 'dh_python')
-rwxr-xr-xdh_python11
1 files changed, 8 insertions, 3 deletions
diff --git a/dh_python b/dh_python
index a101273..857504f 100755
--- a/dh_python
+++ b/dh_python
@@ -18,7 +18,7 @@ B<dh_python> [S<I<debhelper options>>] [B<-n>] [B<-V> I<version>] [S<I<module di
Note: This program is deprecated. You should use dh_pysupport or
dh_pycentral instead. This program will do nothing if debian/pycompat
-exists.
+or a Python-Version control file field exists.
dh_python is a debhelper program that is responsible for generating the
${python:Depends} substitutions and adding them to substvars files. It
@@ -77,8 +77,13 @@ if (-e "debian/pycompat") {
warning("Doing nothing since dh_pycompat exists; dh_pysupport or dh_pycentral should do the work. You can remove dh_python from your rules file.");
exit 0;
}
-
-warning("This program is deprecated, you should use dh_pysupport or dh_pycentral instead.");
+elsif (`grep Python-Version: debian/control`) {
+ warning("Doing nothing since Python-Version is set; dh_pysupport or dh_pycentral should do the work. You can remove dh_python from your rules file.");
+ exit 0;
+}
+else {
+ warning("This program is deprecated, you should use dh_pysupport or dh_pycentral instead.");
+}
my $python = 'python';