summaryrefslogtreecommitdiff
path: root/dh_shlibdeps
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-06-11 14:39:08 -0400
committerJoey Hess <joey@gnu.kitenet.net>2009-06-11 14:39:08 -0400
commit7bbc9917c046d06f7d7e8d7cad10b9e3b27a8ec9 (patch)
treea6bfa98f7ff3c043111e6523f7d7c688600f87b9 /dh_shlibdeps
parent45d6698e772aa6990d6b27a98325cc228d7004fd (diff)
parent15a4917aa7ccfc33b99fd44ba8eb07ab431f81f7 (diff)
Merge branch 'master' into buildsystems
Conflicts: debian/changelog
Diffstat (limited to 'dh_shlibdeps')
-rwxr-xr-xdh_shlibdeps2
1 files changed, 1 insertions, 1 deletions
diff --git a/dh_shlibdeps b/dh_shlibdeps
index 7b974eb8..3ab89818 100755
--- a/dh_shlibdeps
+++ b/dh_shlibdeps
@@ -121,7 +121,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
if (defined($dh{EXCLUDE_FIND}) && $dh{EXCLUDE_FIND} ne '') {
$find_options="! \\( $dh{EXCLUDE_FIND} \\)";
}
- foreach my $file (split(/\n/,`find $tmp -type f \\( -perm +111 -or -name "*.so*" \\) $find_options -print`)) {
+ foreach my $file (split(/\n/,`find $tmp -type f \\( -perm +111 -or -name "*.so*" -or -name "*.cmxs" \\) $find_options -print`)) {
# Prune directories that contain separated debug symbols.
next if $file=~m!^\Q$tmp\E/usr/lib/debug/(lib|lib64|usr|bin|sbin|opt|dev|emul)/!;
# TODO this is slow, optimize. Ie, file can run once on