summaryrefslogtreecommitdiff
path: root/dh_strip
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2011-12-08 19:36:38 -0400
committerJoey Hess <joey@kitenet.net>2011-12-08 19:36:38 -0400
commit71815c9c6ea75ac779d1ff50e7a285c0d9f13bd0 (patch)
tree5870e392388b78caac4e387edd4ee305fabdb9fd /dh_strip
parent35260f3162622e69270028cb5c56a080f32d8556 (diff)
only v9
Reason: http://git.42mm.org/?p=python-greenlet;a=blob;f=debian/rules;h=bd009f86895d496999cd412eac44dbae7b9f1caa;hb=HEAD#l10
Diffstat (limited to 'dh_strip')
-rwxr-xr-xdh_strip4
1 files changed, 2 insertions, 2 deletions
diff --git a/dh_strip b/dh_strip
index be0b000d..57c45f5c 100755
--- a/dh_strip
+++ b/dh_strip
@@ -162,8 +162,8 @@ sub make_debug {
my ($base_file)=$file=~/^\Q$tmp\E(.*)/;
my $debug_path;
- my $elfnotes=`readelf -n $file`;
- if ($elfnotes =~ /^\s+Build ID: ([0-9a-f]{2})([0-9a-f]+)$/m) {
+ if (! compat(8) &&
+ `readelf -n $file`=~ /^\s+Build ID: ([0-9a-f]{2})([0-9a-f]+)$/m) {
$debug_path=$desttmp."/usr/lib/debug/.build-id/$1/$2.debug"
}
else {