summaryrefslogtreecommitdiff
path: root/dh_testdir
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2013-03-20 11:39:44 -0400
committerJoey Hess <joey@kitenet.net>2013-03-20 11:39:44 -0400
commit2cef6101c02593ca5a948a286313e93b1142cf53 (patch)
tree6490ede5d1c6d05a6da42d1c903da833341e176f /dh_testdir
parentc6b2671217ceba031664e5c5ad914f1c92f624c5 (diff)
dh_testdir: Fix error message. Closes: #703515
Diffstat (limited to 'dh_testdir')
-rwxr-xr-xdh_testdir11
1 files changed, 10 insertions, 1 deletions
diff --git a/dh_testdir b/dh_testdir
index 8e12489a..d7e945b9 100755
--- a/dh_testdir
+++ b/dh_testdir
@@ -32,10 +32,19 @@ Test for the existence of these files too.
=cut
+# Run before init because init will try to read debian/control and
+# we want a nicer error message.
+checkfile('debian/control');
+
init();
inhibit_log();
-foreach my $file ('debian/control', @ARGV) {
+foreach my $file (@ARGV) {
+ checkfile($file);
+}
+
+sub checkfile {
+ my $file=shift;
if (! -e $file) {
error("\"$file\" not found. Are you sure you are in the correct directory?");
}