summaryrefslogtreecommitdiff
path: root/dh_testdir
diff options
context:
space:
mode:
authorjoey <joey>1999-08-17 04:12:54 +0000
committerjoey <joey>1999-08-17 04:12:54 +0000
commit938b66ee19e113785e6655b1c3e73e9003e6464c (patch)
treed06bd22faa3da8940bec71ba2e34e2028b6e7764 /dh_testdir
r1: Initial revision
Diffstat (limited to 'dh_testdir')
-rwxr-xr-xdh_testdir14
1 files changed, 14 insertions, 0 deletions
diff --git a/dh_testdir b/dh_testdir
new file mode 100755
index 00000000..4d3c700b
--- /dev/null
+++ b/dh_testdir
@@ -0,0 +1,14 @@
+#!/bin/sh -e
+#
+# Checks to make sure we are building the package in the right directory.
+# Tests for the existance of debian/control, and for the existance
+# of any other files you specify on the command line.
+
+PATH=debian:$PATH:/usr/lib/debhelper
+source dh_lib
+
+for file in debian/control $@; do
+ if [ ! -e "$file" ] ; then
+ error "\"$file\" not found. Are you sure you are in the correct directory?"
+ fi
+done