summaryrefslogtreecommitdiff
path: root/dh_testversion
diff options
context:
space:
mode:
authorjoey <joey>2000-03-02 21:23:22 +0000
committerjoey <joey>2000-03-02 21:23:22 +0000
commit67b74298f08a3e2b30e43cbcd7cdaccc2e1b1614 (patch)
tree3ce180eedb8c91f9371456f3fb40336b4c7c34dd /dh_testversion
parentc7f541bd2bc869c366e8242baf1faa6856cd2e39 (diff)
r338: * Patch from Jorgen `forcer' Schaefer <forcer at mindless.com> (much
modified)to make dh_installwm use new window manager registration method, update-alternatives. Closes: #52156, #34684 (latter bug is obsolete) * Fixed $dh{flavor} to be upper-case. * Deprecated dh_installemavcsen --number; use --priority instead. Also, the option parser requires the parameter be a number now. And, dh_installwm now accepts --priority, and window manager packages should start using it. * dh_installwm now behaves like a proper debhelper command, and reads debian/<package>.wm too. This is a small behavior change; filenames specified on the command line no longer apply to all packages it acts on. I can't belive this program existed for 2 years with such a glaring problem; I guess most people don't need ot register 5 wm's in 3 sub-packages. Anyway, it can handle such things now. :-) * Moved Dh_*.pm to /usr/lib/perl5/Debian/Debhelper. *big* change.
Diffstat (limited to 'dh_testversion')
-rwxr-xr-xdh_testversion9
1 files changed, 4 insertions, 5 deletions
diff --git a/dh_testversion b/dh_testversion
index 57c0e58..8f25214 100755
--- a/dh_testversion
+++ b/dh_testversion
@@ -2,9 +2,8 @@
#
# Debhelper version check.
-BEGIN { push @INC, "debian", "/usr/lib/debhelper" }
-use Dh_Lib;
-use Dh_Version; # contains the version number of debhelper.
+use Debian::Debhelper::Dh_Lib;
+use Debian::Debhelper::Dh_Version; # contains the version number of debhelper.
init();
my($compare, $ver);
@@ -19,6 +18,6 @@ elsif ($#ARGV eq 0) {
}
if (defined $compare and defined $ver) {
- system('dpkg','--compare-versions',$Dh_Version::version,$compare,$ver) == 0 ||
- error("debhelper version $Dh_Version::version is installed, but a version $compare $ver is needed to build this package.");
+ system('dpkg','--compare-versions',$Debian::Debhelper::Dh_Version::version,$compare,$ver) == 0 ||
+ error("debhelper version $Debian::Debhelper::Dh_Version::version is installed, but a version $compare $ver is needed to build this package.");
}