summaryrefslogtreecommitdiff
path: root/dh_undocumented
diff options
context:
space:
mode:
authorjoey <joey>2001-11-17 21:01:33 +0000
committerjoey <joey>2001-11-17 21:01:33 +0000
commit2d76f9e8cf76146e7b24ac4232918f584cfb8a16 (patch)
tree0d68cc6e0a8f3be71b0f3e45d4c5177a564fa189 /dh_undocumented
parentda77014a9f5c7467c47e527e70a7fb8c433595c7 (diff)
r495: * dh_undocumented: check for existing uncompressed man pages. Closes: #87972
* Optimized dh_installdeb conffile finding. Closes: #119035 * dh_installdeb: changed the #!/bin/sh -e to set -e on a new line. Whether this additional bloat is worth it to make it easier for people to sh -x a script by hand is debatable either way, I guess. Closes: #119046 * Added a check for duplicated package stanzas in debian/control, Closes: #118805
Diffstat (limited to 'dh_undocumented')
-rwxr-xr-xdh_undocumented10
1 files changed, 8 insertions, 2 deletions
diff --git a/dh_undocumented b/dh_undocumented
index 2242ffd6..da96473e 100755
--- a/dh_undocumented
+++ b/dh_undocumented
@@ -78,7 +78,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# Determine what directory the file belongs in,
# /usr/share/man, or /usr/X11R6/man, and how the link to
- # the undocuemtned.7 man page will look.
+ # the undocumented.7 man page will look.
my ($dir, $reldir);
my ($section)=$file=~m/^.*\.(\d)/;
if (!$section) {
@@ -93,9 +93,15 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
$reldir="";
}
+ # If an uncompressed version of the page exists, something
+ # is weird.
+ if (-e "$tmp/$dir/$file") {
+ error("A man page $tmp/$dir/$file exists.");
+ }
+
if (! -d "$tmp/$dir") {
doit("install","-d","$tmp/$dir");
- }
+ }
doit("ln","-sf","${reldir}undocumented.7.gz","$tmp/$dir/$file.gz");
}
}