summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorjoey <joey>2004-02-09 05:24:40 +0000
committerjoey <joey>2004-02-09 05:24:40 +0000
commit4f162e192c3563d740490cc99ced1513104ac34c (patch)
treeb521746cbacfde4afc5af4031b767d1f87101a83 /doc
parentad3f34f9653fe848816f2af915b9cdd260fc4421 (diff)
r1655: * Added udeb support, as pioneered by di-packages-build. Understands
"XC-Package-Type: udeb" in debian/control. See debhelper(1) for details. * Dh_Lib: add and export is_udeb and udeb_filename * dh_builddeb: name udebs with proper extension * dh_gencontrol: pass -n and filename to dpkg-gencontrol * dh_installdocs, dh_makeshlibs, dh_md5sums, dh_installchangelogs, dh_installexamples, dh_installman, dh_installmanpages: skip udebs * dh_shlibdeps: skip udebs. This may be temporary. * dh_installdeb: do not process conffiles, shlibs, preinsts, postrms, or prerms for udebs. Do not substiture #DEBHELPER# tokens in postinst scripts for udebs. * dh_installdebconf: skip config script for udebs, still do templates
Diffstat (limited to 'doc')
-rw-r--r--doc/PROGRAMMING5
1 files changed, 5 insertions, 0 deletions
diff --git a/doc/PROGRAMMING b/doc/PROGRAMMING
index 239f53e7..5a3156e1 100644
--- a/doc/PROGRAMMING
+++ b/doc/PROGRAMMING
@@ -237,5 +237,10 @@ delsubstvar($package, $substvar)
excludefile($filename)
This function returns true if -X has been used to ask for the file
to be excluded.
+is_udeb($package)
+ Returns true if the package is marked as a udeb in the control
+ file.
+udeb_filename($package)
+ Returns the filename of the udeb package.
-- Joey Hess <joeyh@debian.org>