summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2012-01-15 14:22:28 -0400
committerJoey Hess <joey@kitenet.net>2012-01-15 14:24:21 -0400
commit78d072a8d942283723d94fbfb8f40e61d1f7fbe4 (patch)
tree0a8849bb506ab43493fc111e24268f7ba8878b73 /doc
parent6e71ad3aef68ca74a891f61e7a1ed34b053c0dc0 (diff)
v9 done
* Finalized v9 mode, which is the new recommended default. (But continuing to use v8 is also fine.) * It is now deprecated for a package to not specify a compatability level in debian/compat. Debhelper now warns if this is not done, and packages without a debian/compat will eventually FTBFS.
Diffstat (limited to 'doc')
-rw-r--r--doc/TODO4
1 files changed, 3 insertions, 1 deletions
diff --git a/doc/TODO b/doc/TODO
index 573917f..cd2721f 100644
--- a/doc/TODO
+++ b/doc/TODO
@@ -1,10 +1,12 @@
-v9:
+v10:
* escaping in config files (for whitespace)?
* dh_installinit --restart-after-upgrade as default?
Deprecated:
+* make a missing debian/compat an error. (started printing warning messages
+ in 20120115)
* DH_COMPAT 1, 2, 3, 4. Can be removed once all packages are seen to be using
a newer version. I won't hold my breath. (2 and 3 are getting close though.)
* dh_suidregister. Once nothing in the archive uses it.