summaryrefslogtreecommitdiff
path: root/examples/rules.indep
diff options
context:
space:
mode:
authorjoey <joey>1999-08-17 04:34:24 +0000
committerjoey <joey>1999-08-17 04:34:24 +0000
commit1e6dea44772a0c1f57e7cd50ff12e35a1cff0b96 (patch)
tree212e56dc8ea32cf27cd2a33ac901a92a701f063f /examples/rules.indep
parentface7b5d7df5fb2b8f434bc7135f27b38329a5c5 (diff)
r11: Initial revision
Diffstat (limited to 'examples/rules.indep')
-rwxr-xr-xexamples/rules.indep56
1 files changed, 56 insertions, 0 deletions
diff --git a/examples/rules.indep b/examples/rules.indep
new file mode 100755
index 00000000..a257a197
--- /dev/null
+++ b/examples/rules.indep
@@ -0,0 +1,56 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
+# This version is for packages that are architecure independant.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+build: build-stamp
+build-stamp:
+ dh_testdir
+ # Add here commands to compile the pacckage.
+ #$(MAKE)
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp
+ # Add here commands to clean up after the build process.
+ #-$(MAKE) distclean
+ dh_clean
+
+# Build architecture-independent files here.
+binary-indep: build
+ dh_testdir
+ dh_testroot
+ dh_clean
+ dh_installdirs
+ # Add here commands to install the files into debian/tmp
+ #$(MAKE) PREFIX=debian/tmp install
+ dh_installdocs
+ dh_installexamples
+ dh_installmenu
+# dh_installinit
+ dh_installcron
+# dh_installmanpages
+# dh_undocumented
+ dh_installchangelogs
+ dh_compress
+ dh_fixperms
+ dh_suidregister
+ dh_installdeb
+ dh_gencontrol
+ dh_du
+ dh_md5sums
+ dh_builddeb
+
+# Build architecture-dependent files here.
+binary-arch: build
+# We have nothing to do by default.
+
+source diff:
+ @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary