summaryrefslogtreecommitdiff
path: root/examples/rules.multi2
diff options
context:
space:
mode:
authorjoey <joey>1999-09-30 19:50:06 +0000
committerjoey <joey>1999-09-30 19:50:06 +0000
commite1fb0a64cfe30960aa4edacf224921b888443dc8 (patch)
tree2a0ceb3088ab9b398fd4e520ef3aa3d72bfdd3b9 /examples/rules.multi2
parentc57d49934a1500acb3dafaaf32da8bbef1b52314 (diff)
r286: * Fiddlesticks. The neat make trick I was using in rules.multi2 failed if
you try to build binary-indep and binary-arch targets in the same make run. Make tries to be too smart. Modified the file so it will work, though it's now uglier. Closes: 46287 * examples/*: It's important that one -not- use a install-stamp target. Install should run every time binary-* calls it. Otherwise if a binary-* target is called twice by hand, you get duplicate entries in the maintainer script fragment files. Closes: #46313
Diffstat (limited to 'examples/rules.multi2')
-rwxr-xr-xexamples/rules.multi29
1 files changed, 4 insertions, 5 deletions
diff --git a/examples/rules.multi2 b/examples/rules.multi2
index 871c41c7..1f773311 100755
--- a/examples/rules.multi2
+++ b/examples/rules.multi2
@@ -83,13 +83,12 @@ binary-common:
# Build architecture independant packages using the common target.
# (Uncomment the next two lines and comment out the third if you have
# such packages)
-#binary-indep: DH_OPTIONS=-i
-#binary-indep: build install binary-common
-binary-indep:
+#binary-indep:
+# $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
# Build architecture dependant packages using the common target.
-binary-arch: DH_OPTIONS=-a
-binary-arch: build install binary-common
+binary-arch:
+ $(MAKE) -f debian/rules DH_OPTIONS=-a binary-common
# Any other binary targets build just one binary package at a time.
binary-%: build install