summaryrefslogtreecommitdiff
path: root/examples/rules.multi2
diff options
context:
space:
mode:
authorjoey <joey>2002-04-12 03:04:35 +0000
committerjoey <joey>2002-04-12 03:04:35 +0000
commit29fd2dcb7d861e78f8b5855abd06364e8d60c2ed (patch)
treeab18887fe7bba32e72f842d5b685181df239c93d /examples/rules.multi2
parentea383ca972213bdda50226c536e3224a361904b8 (diff)
r518: * dh_movefiles has long been a sore point in debhelper. Inherited
from debstd, its interface and implementation suck, and I have maintained it while never really deigning to use it. Now there is a remplacment: dh_install, which ... - copies files, doesn't move them. Closes: #75360, #82649 - doesn't have that whole annoying debian/package.files vs. debian/files mess, as it uses debian/install. - supports copying empty subdirs. Closes: #133037 - doesn't use tar, thus no error reproting problems. Closes: #112538 - files are listed relative to the pwd, debian/tmp need not be used at all, so no globbing issues. Closes: #100404 - supports -X. Closes: #116902 - the whole concept of moving files out of a directory is gone, so this bug doesn't really apply. Closes: #120026 - This is exactly what Bill Allombert asked for in #117383, even though I designed it seemingly independantly. Thank you Bill! Closes: #117383 * Made debhelper's debian/rules a lot simpler by means of the above. * Updated example rules file to use dh_install. Also some reordering and other minor changes. * dh_movefiles is lightly deprecated, and when you run into its bugs and bad design, you are incouraged to just use dh_install instead. * dh_fixperms: in v4 only, make all files in bin/ dirs +x. Closes: #119039 * dh_fixperms: in v4 only, make all files in etc/init.d executable (of course there's -X ..) * dh_link: in v4 only, finds existing, non-policy-conformant symlinks and corrects them. This has the side effect of making dh_link idempotent. * Added a -h/--help option. This seems very obvious, but it never occured to me before.. * use v4 for building debhelper itself * v4 mode is done, you may now use it without fear of it changing. (This idea of this upload is to get v4 into woody so people won't run into many issues backporting from sarge to woody later on. Packages targeted for woody should continue to use whatever compatability level they are using.)
Diffstat (limited to 'examples/rules.multi2')
-rwxr-xr-xexamples/rules.multi211
1 files changed, 6 insertions, 5 deletions
diff --git a/examples/rules.multi2 b/examples/rules.multi2
index 4434b0c0..edde0b8d 100755
--- a/examples/rules.multi2
+++ b/examples/rules.multi2
@@ -41,7 +41,7 @@ install: build
# Add here commands to install the package into debian/tmp.
#$(MAKE) prefix=`pwd`/debian/tmp/usr install
- dh_movefiles
+ dh_install
# This single target is used to build all the packages, all at once, or
# one at a time. So keep in mind: any options passed to commands here will
@@ -50,20 +50,21 @@ install: build
binary-common:
dh_testdir
dh_testroot
-# dh_installdebconf
+ dh_installchangelogs
dh_installdocs
dh_installexamples
dh_installmenu
+# dh_installdebconf
# dh_installlogrotate
# dh_installemacsen
# dh_installpam
# dh_installmime
# dh_installinit
# dh_installman
- dh_installcron
- dh_installinfo
+# dh_installcron
+# dh_installinfo
# dh_undocumented
- dh_installchangelogs
+ dh_installman
dh_strip
dh_link
dh_compress