summaryrefslogtreecommitdiff
path: root/examples/rules
diff options
context:
space:
mode:
authorJoey Hess <joey@kodama.kitenet.net>2008-04-23 19:14:56 -0400
committerJoey Hess <joey@kodama.kitenet.net>2008-04-23 19:14:56 -0400
commit26f1964c1dec6991f12ef19cde2974bc6abdbb18 (patch)
treeaf2c9f42578bf5924390f92e830b53cde71d3d14 /examples/rules
parent709cc5dfd66b5c061327d6fc6cb6b2df55c18d4e (diff)
initial version of dh, with option parsing and sequences in place
Diffstat (limited to 'examples/rules')
-rwxr-xr-xexamples/rules78
1 files changed, 0 insertions, 78 deletions
diff --git a/examples/rules b/examples/rules
deleted file mode 100755
index e4619828..00000000
--- a/examples/rules
+++ /dev/null
@@ -1,78 +0,0 @@
-#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# This file is public domain software, originally written by Joey Hess.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-build: build-stamp
-build-stamp:
- dh_testdir
-
- # Add here commands to compile the package.
- #$(MAKE)
-
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp
-
- # Add here commands to clean up after the build process.
- #$(MAKE) clean
- #$(MAKE) distclean
-
- dh_clean
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- # Add here commands to install the package into debian/<packagename>
- #$(MAKE) prefix=`pwd`/debian/`dh_listpackages`/usr install
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs
- dh_installdocs
- dh_installexamples
-# dh_install
-# dh_installmenu
-# dh_installdebconf
-# dh_installlogrotate
-# dh_installemacsen
-# dh_installcatalogs
-# dh_installpam
-# dh_installmime
-# dh_installinit
-# dh_installcron
-# dh_installinfo
-# dh_installwm
-# dh_installudev
-# dh_lintian
-# dh_undocumented
- dh_installman
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
-# dh_perl
-# dh_python
-# dh_makeshlibs
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install