summaryrefslogtreecommitdiff
path: root/examples/rules
diff options
context:
space:
mode:
authorjoey <joey>1999-09-03 21:12:04 +0000
committerjoey <joey>1999-09-03 21:12:04 +0000
commitda7d6c32c080678dc672f7c6e680c11569f46eda (patch)
tree437e68fc95e8b49b4339f30ae9ca111a005e72b3 /examples/rules
parent60037371809ab782c2d675ea1bfc849c2772fce2 (diff)
r265: * It turns out it's possible to set up make variables that are specific to
a single target of a Makefile. This works tremendously well with DH_OPTIONS: no need to put "-i" or "-pfoo" after every debhelper command anymore. * debhelper.1: mentioned above technique. * examples/rules.multi: use the above method to get rid of -i's and -a's. * examples/rules.multi2: new file, example of a multi-binary package that works for arch-indep and arch-dependant packages, and also allows building of single binary packages independntly, via binary-<package> targets. It accomplishes all this using only one list of debhelper commands. * examples/*: removed source and diff targets. They've been obsolete for 2 years -- or is it 3? No need for a nice error message on failure anymore.
Diffstat (limited to 'examples/rules')
-rwxr-xr-xexamples/rules61
1 files changed, 49 insertions, 12 deletions
diff --git a/examples/rules b/examples/rules
index e6ebf0b0..926c38c6 100755
--- a/examples/rules
+++ b/examples/rules
@@ -1,41 +1,78 @@
#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+# This is the debhelper compatability version to use.
+export DH_COMPAT=1
build: build-stamp
build-stamp:
dh_testdir
- # Add here commands to compile the pacckage.
+
+ # Add here commands to compile the package.
#$(MAKE)
+
touch build-stamp
clean:
dh_testdir
dh_testroot
- dh_cleantmp
+ rm -f build-stamp install-stamp
+
# Add here commands to clean up after the build process.
+ #-$(MAKE) clean
#-$(MAKE) distclean
- rm -f build-stamp
+
+ dh_clean
+
+install: install-stamp
+install-stamp: build-stamp
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/tmp.
+ #$(MAKE) prefix=`pwd`/debian/tmp/usr install
+
+ touch install-stamp
# Build architecture-independent files here.
-binary-indep: build
- # We have nothing to do by default.
+binary-indep: build install
+# We have nothing to do by default.
# Build architecture-dependent files here.
-binary-arch: build
+binary-arch: build install
+# dh_testversion
dh_testdir
dh_testroot
- dh_cleantmp
- # Add here commands to install the files into debian/tmp
- #$(MAKE) PREFIX=debian/tmp install
dh_installdocs
dh_installexamples
dh_installmenu
+# dh_installemacsen
+# dh_installpam
+# dh_installinit
+ dh_installcron
dh_installmanpages
+ dh_installinfo
+# dh_undocumented
dh_installchangelogs
+ dh_link
+ dh_strip
dh_compress
- dh_installdebfiles
dh_fixperms
+ # You may want to make some executables suid here.
+ dh_suidregister
+# dh_makeshlibs
+ dh_installdeb
+# dh_perl
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
dh_builddeb
binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary
+.PHONY: build clean binary-indep binary-arch binary install