summaryrefslogtreecommitdiff
path: root/examples
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-02-16 14:55:55 -0500
committerJoey Hess <joey@gnu.kitenet.net>2009-02-16 14:55:55 -0500
commit0f3f59fe6058edfda4010dc88bd3b8aa3ae70a6d (patch)
tree620de8f75a33cc930ca3a9ba88e92a9ee834da61 /examples
parent9e9f49c03fe968effe2ade343d8665386bc8e4c2 (diff)
dh override targets
* dh: debian/rules override targets can change what is run for a specific debhelper command in a sequence. * dh: Redid all the examples to use override targets, since these eliminate all annoying boilerplate and are much easier to understand than the old method. * Remove rules.simple example, there's no need to use explcit targets with dh anymore.
Diffstat (limited to 'examples')
-rwxr-xr-xexamples/rules.simple22
1 files changed, 0 insertions, 22 deletions
diff --git a/examples/rules.simple b/examples/rules.simple
deleted file mode 100755
index ab49db98..00000000
--- a/examples/rules.simple
+++ /dev/null
@@ -1,22 +0,0 @@
-#!/usr/bin/make -f
-
-build: build-stamp
-build-stamp:
- dh build
- touch build-stamp
-
-clean:
- dh clean
-
-install: build install-stamp
-install-stamp:
- dh install
- touch install-stamp
-
-binary-arch: install
- dh binary-arch
-
-binary-indep: install
- dh binary-indep
-
-binary: binary-arch binary-indep