summaryrefslogtreecommitdiff
path: root/t/buildsystems/buildsystem_tests
diff options
context:
space:
mode:
authorModestas Vainius <modestas@vainius.eu>2009-11-19 20:58:39 +0200
committerJoey Hess <joey@gnu.kitenet.net>2009-11-19 14:52:14 -0500
commit25d57ca95f7571e13dbba4a0ae82c43d5e0e5a06 (patch)
tree29562b57dade5f82710da21031a4a4e840592d7c /t/buildsystems/buildsystem_tests
parentb473ba8f7c4eb5084c71362b4e04133dda3e62ec (diff)
cmake build+ steps need Makefile.
The condition is not what dh_auto_* 7.0.x would have done. The patch makes auto-selection to pass through cmake.pm if Makefile was not created. This problem is not very dangerous though.
Diffstat (limited to 't/buildsystems/buildsystem_tests')
-rwxr-xr-xt/buildsystems/buildsystem_tests2
1 files changed, 1 insertions, 1 deletions
diff --git a/t/buildsystems/buildsystem_tests b/t/buildsystems/buildsystem_tests
index e19ab5de..d8619fc1 100755
--- a/t/buildsystems/buildsystem_tests
+++ b/t/buildsystems/buildsystem_tests
@@ -256,7 +256,7 @@ touch "$tmpdir/configure", 0755;
test_check_auto_buildable($bs{autoconf}, "configure", { configure => 1 });
touch "$tmpdir/CMakeLists.txt";
-test_check_auto_buildable($bs{cmake}, "CMakeLists.txt", 1);
+test_check_auto_buildable($bs{cmake}, "CMakeLists.txt", { configure => 1 });
touch "$tmpdir/Makefile.PL";
test_check_auto_buildable($bs{perl_makemaker}, "Makefile.PL", { configure => 1 });