summaryrefslogtreecommitdiff
path: root/t/buildsystems
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-11-23 14:18:32 -0500
committerJoey Hess <joey@gnu.kitenet.net>2009-11-23 14:18:32 -0500
commit6dd27753803ae2091a9fc3aedc8e70548ea87675 (patch)
treefa754dc2cd36eecf4ebbca0145d86dea74a592b0 /t/buildsystems
parent23ffaf8d5b6ac116b3f489c30fb57d32b1ca9c0f (diff)
update for no-paralle-by-default change
Diffstat (limited to 't/buildsystems')
-rwxr-xr-xt/buildsystems/buildsystem_tests18
1 files changed, 9 insertions, 9 deletions
diff --git a/t/buildsystems/buildsystem_tests b/t/buildsystems/buildsystem_tests
index d8619fc1..93e937a1 100755
--- a/t/buildsystems/buildsystem_tests
+++ b/t/buildsystems/buildsystem_tests
@@ -574,7 +574,7 @@ test_isnt_parallel( do_parallel_mk(),
"No parallel by default" );
$ENV{DEB_BUILD_OPTIONS}="parallel=5";
-test_is_parallel( do_parallel_mk(),
+test_isnt_parallel( do_parallel_mk(),
"DEB_BUILD_OPTIONS=parallel=5 without --max-parallel" );
test_is_parallel( do_parallel_mk("--max-parallel=2"),
"DEB_BUILD_OPTIONS=parallel=5 with --max-parallel=2" );
@@ -583,10 +583,10 @@ test_isnt_parallel( do_parallel_mk("--max-parallel=1"),
$ENV{MAKEFLAGS} = "--jobserver-fds=105,106 -j";
$ENV{DEB_BUILD_OPTIONS}="";
-test_isnt_parallel( do_parallel_mk(),
+test_isnt_parallel( do_parallel_mk("--max-parallel=5"),
"makefile.pm (no parallel): no make warnings about unavailable jobserver" );
$ENV{DEB_BUILD_OPTIONS}="parallel=5";
-test_is_parallel( do_parallel_mk(),
+test_is_parallel( do_parallel_mk("--max-paralle=5"),
"DEB_BUILD_OPTIONS=parallel=5: no make warnings about unavail parent jobserver" );
$ENV{MAKEFLAGS} = "-j2";
@@ -622,7 +622,7 @@ sub test_dh_parallel {
$rules = <<'EOF';
%:
@dh_clean > /dev/null 2>&1
- @dh --buildsystem=makefile --after=dh_auto_configure --until=dh_auto_build $@
+ @dh --buildsystem=makefile --max-parallel=5 --after=dh_auto_configure --until=dh_auto_build $@
@dh_clean > /dev/null 2>&1
EOF
@@ -643,7 +643,7 @@ EOF
$rules = <<'EOF';
%:
@dh_clean > /dev/null 2>&1
- @dh -j --buildsystem=makefile --after=dh_auto_configure --until=dh_auto_build $@
+ @dh -j --buildsystem=makefile --max-parallel=5 --after=dh_auto_configure --until=dh_auto_build $@
@dh_clean > /dev/null 2>&1
EOF
test_is_parallel( do_rules_for_parallel("build", $rules),
@@ -675,7 +675,7 @@ $tmp = write_debian_rules(<<'EOF');
#!/usr/bin/make -f
%:
@dh_clean > /dev/null 2>&1
- @+dh --buildsystem=makefile --after=dh_auto_configure --until=dh_auto_build $@
+ @+dh --buildsystem=makefile --max-parallel=5 --after=dh_auto_configure --until=dh_auto_build $@
@dh_clean > /dev/null 2>&1
EOF
test_is_parallel( do_rules_for_parallel("build", "include debian/rules"),
@@ -688,7 +688,7 @@ override_dh_auto_build:
dh_auto_build
%:
@dh_clean > /dev/null 2>&1
- @+dh --buildsystem=makefile --after=dh_auto_configure --until=dh_auto_build $@
+ @+dh --buildsystem=makefile --max-parallel=5 --after=dh_auto_configure --until=dh_auto_build $@
@dh_clean > /dev/null 2>&1
EOF
test_is_parallel( do_rules_for_parallel("build", "include debian/rules"),
@@ -701,7 +701,7 @@ override_dh_auto_build:
+dh_auto_build
%:
@dh_clean > /dev/null 2>&1
- @+dh --buildsystem=makefile --after=dh_auto_configure --until=dh_auto_build $@
+ @+dh --buildsystem=makefile --max-parallel=5 --after=dh_auto_configure --until=dh_auto_build $@
@dh_clean > /dev/null 2>&1
EOF
test_is_parallel( do_rules_for_parallel("build", "include debian/rules"),
@@ -714,7 +714,7 @@ override_dh_auto_build:
$(MAKE)
%:
@dh_clean > /dev/null 2>&1
- @+dh --buildsystem=makefile --after=dh_auto_configure --until=dh_auto_build $@
+ @+dh --buildsystem=makefile --max-parallel=5 --after=dh_auto_configure --until=dh_auto_build $@
@dh_clean > /dev/null 2>&1
EOF
test_is_parallel( do_rules_for_parallel("build", "include debian/rules"),