summaryrefslogtreecommitdiff
path: root/t/buildsystems
diff options
context:
space:
mode:
authorModestas Vainius <modestas@vainius.eu>2009-12-04 00:02:01 +0200
committerJoey Hess <joey@gnu.kitenet.net>2009-12-04 15:00:45 -0500
commitbd97b09925d8e72b19804f831bc6237509bfbff1 (patch)
tree3217816d8b45441d76936b49b5d0f2da3c80f9ec /t/buildsystems
parentce069424bc9a14aaefc06871d0ea530c0e26bbb7 (diff)
Sometimes SIGINTing the test suite leaves Makefile behind.
So use -f for ln. It is safe. (cherry picked from commit d89a2c6d2c7148f6e890c0c11e64b92982d3f869)
Diffstat (limited to 't/buildsystems')
-rwxr-xr-xt/buildsystems/buildsystem_tests2
1 files changed, 1 insertions, 1 deletions
diff --git a/t/buildsystems/buildsystem_tests b/t/buildsystems/buildsystem_tests
index 2204f3f5..1a9e21ca 100755
--- a/t/buildsystems/buildsystem_tests
+++ b/t/buildsystems/buildsystem_tests
@@ -604,7 +604,7 @@ sub do_rules_for_parallel {
"make -f - $cmdline 2>&1 >/dev/null", $stdin);
}
-doit("ln", "-s", "parallel.mk", "Makefile");
+doit("ln", "-sf", "parallel.mk", "Makefile");
# Test if dh+override+$(MAKE) legacy punctuation hack work as before
$ENV{MAKEFLAGS} = "-j5";