summaryrefslogtreecommitdiff
path: root/t/dh_install
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-07-15 09:50:47 -0400
committerJoey Hess <joey@gnu.kitenet.net>2009-07-15 09:50:47 -0400
commitd92a7906608dcf6c697e912f73376c7f6b030fa8 (patch)
treec93b14ad35563c0f172101311db1ea688eca2903 /t/dh_install
parentfba7d9e67576b17ed5eb4da99e5d1882549b5985 (diff)
parent452b7e6a61be42b2c345cdeeb00fbe51f88fce32 (diff)
Merge branch 'master' into buildsystems
Conflicts: debian/changelog
Diffstat (limited to 't/dh_install')
-rwxr-xr-xt/dh_install48
1 files changed, 48 insertions, 0 deletions
diff --git a/t/dh_install b/t/dh_install
new file mode 100755
index 00000000..37aff7b2
--- /dev/null
+++ b/t/dh_install
@@ -0,0 +1,48 @@
+#!/usr/bin/perl
+use Test;
+plan(tests => 13);
+
+system("rm -rf debian/debhelper debian/tmp");
+
+# #537140: debian/tmp is explcitly specified despite being searched by
+# default in v7+
+system("mkdir -p debian/tmp/usr/bin; touch debian/tmp/usr/bin/foo; touch debian/tmp/usr/bin/bar");
+system("./dh_install", "debian/tmp/usr/bin/foo");
+ok(-e "debian/debhelper/usr/bin/foo");
+ok(! -e "debian/debhelper/usr/bin/bar");
+system("rm -rf debian/debhelper debian/tmp");
+
+# #537017: --sourcedir=debian/tmp/foo is used
+system("mkdir -p debian/tmp/foo/usr/bin; touch debian/tmp/foo/usr/bin/foo; touch debian/tmp/foo/usr/bin/bar");
+system("./dh_install", "--sourcedir=debian/tmp/foo", "usr/bin/bar");
+ok(-e "debian/debhelper/usr/bin/bar");
+ok(! -e "debian/debhelper/usr/bin/foo");
+system("rm -rf debian/debhelper debian/tmp");
+
+# #535367: installation of entire top-level directory from debian/tmp
+system("mkdir -p debian/tmp/usr/bin; touch debian/tmp/usr/bin/foo; touch debian/tmp/usr/bin/bar");
+system("./dh_install", "usr");
+ok(-e "debian/debhelper/usr/bin/foo");
+ok(-e "debian/debhelper/usr/bin/bar");
+system("rm -rf debian/debhelper debian/tmp");
+
+# #534565: fallback use of debian/tmp in v7+
+system("mkdir -p debian/tmp/usr/bin; touch debian/tmp/usr/bin/foo; touch debian/tmp/usr/bin/bar");
+system("./dh_install", "usr/bin");
+ok(-e "debian/debhelper/usr/bin/foo");
+ok(-e "debian/debhelper/usr/bin/bar");
+system("rm -rf debian/debhelper debian/tmp");
+
+# #534565: glob expands to dangling symlink -> should install the dangling link
+system("mkdir -p debian/tmp/usr/bin; ln -s broken debian/tmp/usr/bin/foo; touch debian/tmp/usr/bin/bar");
+system("./dh_install", "usr/bin/*");
+ok(-l "debian/debhelper/usr/bin/foo");
+ok(! -e "debian/debhelper/usr/bin/foo");
+ok(-e "debian/debhelper/usr/bin/bar");
+ok(! -l "debian/debhelper/usr/bin/bar");
+system("rm -rf debian/debhelper debian/tmp");
+
+# regular specification of file not in debian/tmp
+system("./dh_install", "dh_install", "usr/bin");
+ok(-e "debian/debhelper/usr/bin/dh_install");
+system("rm -rf debian/debhelper debian/tmp");