summaryrefslogtreecommitdiff
path: root/t/maintscript
diff options
context:
space:
mode:
authorJoey Hess <joeyh@debian.org>2013-09-21 13:16:34 -0400
committerJoey Hess <joeyh@debian.org>2013-09-21 13:16:34 -0400
commit775d1ca63964312b7f519edfe0cce476669617f6 (patch)
tree29834fd91c532ee93aec9dfe6e8f1fc4e19019f7 /t/maintscript
debhelper (9.20130921) unstable; urgency=low
* dh: Call dh_installxfonts after dh_link, so that it will notice fonts installed via symlinks. Closes: #721264 * Fix FTBFS with perl 5.18. Closes: #722501 * dh_installchangelogs: Add changelog.md to the list of common changelog filenames. # imported from the archive
Diffstat (limited to 't/maintscript')
-rw-r--r--t/maintscript19
1 files changed, 19 insertions, 0 deletions
diff --git a/t/maintscript b/t/maintscript
new file mode 100644
index 00000000..bf15d445
--- /dev/null
+++ b/t/maintscript
@@ -0,0 +1,19 @@
+#!/usr/bin/perl
+use Test;
+plan(tests => 8);
+
+system("mkdir -p t/tmp/debian");
+system("cp debian/control t/tmp/debian");
+open(OUT, ">", "t/tmp/debian/maintscript") || die "$!";
+print OUT <<EOF;
+rm_conffile /etc/1
+mv_conffile /etc/2 /etc/3 1.0-1
+EOF
+close OUT;
+system("cd t/tmp && DH_COMPAT=7 fakeroot ../../dh_installdeb");
+for my $script (qw{postinst preinst prerm postrm}) {
+ my @output=`cat t/tmp/debian/debhelper.$script.debhelper`;
+ ok(grep { m{^dpkg-maintscript-helper rm_conffile /etc/1 -- "\$\@"$} } @output);
+ ok(grep { m{^dpkg-maintscript-helper mv_conffile /etc/2 /etc/3 1\.0-1 -- "\$\@"$} } @output);
+}
+system("rm -rf t/tmp");