summaryrefslogtreecommitdiff
path: root/t/syntax
diff options
context:
space:
mode:
authorjoey <joey>2005-11-07 20:16:50 +0000
committerjoey <joey>2005-11-07 20:16:50 +0000
commitc871b973337d20ab75e2753dbd8902c8e5c49a8c (patch)
tree5ab9ef2c2ef54dd077ccc57fa1b92d6481558669 /t/syntax
parent5d54e11cfb37e982fe73190be95dbb688ad58dce (diff)
r1811: * Remove dh_shlibs from binary-indep section of debian/rules.
* Add t/syntax to make sure all dh_* commands and the libraries syntax check ok.
Diffstat (limited to 't/syntax')
-rw-r--r--t/syntax11
1 files changed, 11 insertions, 0 deletions
diff --git a/t/syntax b/t/syntax
new file mode 100644
index 00000000..b647b915
--- /dev/null
+++ b/t/syntax
@@ -0,0 +1,11 @@
+#!/usr/bin/perl
+use Test;
+
+my @progs=grep { -x $_ } glob("dh_*");
+my @libs=glob("Debian/Debhelper/*.pm");
+
+plan(tests => (@progs + @libs));
+
+foreach my $file (@progs, @libs) {
+ ok(system("perl -c $file >/dev/null 2>&1"), 0);
+}