summaryrefslogtreecommitdiff
path: root/t
diff options
context:
space:
mode:
authorModestas Vainius <modax@debian.org>2011-07-21 14:48:57 +0300
committerJoey Hess <joey@kitenet.net>2011-08-05 13:43:02 -0400
commitf2123b6963a0c59d4901037f519376c1ce660177 (patch)
treeac7771427a704ca728f2f55217ad7299c3f8cf50 /t
parent7da05db96ef52c0f3367538c2b197341484a70c2 (diff)
makefile.pm: remove build directory even if Makefile does not exist yet.
Assume that the package can be cleaned (i.e. the build directory can be removed) as long as it is built out-of-source tree and can be configured. This is useful for derivative buildsystems which generate Makefiles.
Diffstat (limited to 't')
-rwxr-xr-xt/buildsystems/buildsystem_tests2
1 files changed, 1 insertions, 1 deletions
diff --git a/t/buildsystems/buildsystem_tests b/t/buildsystems/buildsystem_tests
index c6f23ca5..3b45ac5e 100755
--- a/t/buildsystems/buildsystem_tests
+++ b/t/buildsystems/buildsystem_tests
@@ -256,7 +256,7 @@ touch "$tmpdir/configure", 0755;
test_check_auto_buildable($bs{autoconf}, "configure", { configure => 1 });
touch "$tmpdir/CMakeLists.txt";
-test_check_auto_buildable($bs{cmake}, "CMakeLists.txt", { configure => 1 });
+test_check_auto_buildable($bs{cmake}, "CMakeLists.txt", { configure => 1, clean => 1 });
touch "$tmpdir/Makefile.PL";
test_check_auto_buildable($bs{perl_makemaker}, "Makefile.PL", { configure => 1 });