summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Buildsystem.pm2
-rw-r--r--debian/changelog2
2 files changed, 3 insertions, 1 deletions
diff --git a/Debian/Debhelper/Buildsystem.pm b/Debian/Debhelper/Buildsystem.pm
index f729c0da..88aefab3 100644
--- a/Debian/Debhelper/Buildsystem.pm
+++ b/Debian/Debhelper/Buildsystem.pm
@@ -96,7 +96,7 @@ sub _set_builddir {
$builddir = File::Spec->catdir($this->{cwd}, $builddir);
}
elsif ($builddir =~ /\Q$this->{cwd}\E/) {
- $builddir = File::Spec::abs2rel($builddir, $this->{cwd});
+ $builddir = File::Spec->abs2rel($builddir, $this->{cwd});
}
# If build directory ends up the same as source directory, drop it
diff --git a/debian/changelog b/debian/changelog
index 7858a5d6..51a4ac00 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -11,6 +11,8 @@ debhelper (7.4.12) UNRELEASED; urgency=low
that do not support -B would see a bogus -u option. Closes: #541773
(It also ensures that the commands dh prints out can really be run.)
* qmake: New buildsystem contributed by Kel Modderman. Closes: #566840
+ * Fix typo in call to abs2rel in --builddir sanitize code.
+ Closes: #567737
-- Joey Hess <joeyh@debian.org> Fri, 01 Jan 2010 13:00:22 -0500