summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Dh_Lib.pm2
-rwxr-xr-xdebian/rules2
2 files changed, 2 insertions, 2 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index 80645abe..87677580 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -553,7 +553,7 @@ sub excludefile {
sub buildarch {
return $arch if defined $arch;
- $arch=`dpkg-architecture -qDEB_HOST_ARCH 2>/dev/null` || error($!);
+ $arch=`dpkg-architecture -qDEB_HOST_ARCH 2>/dev/null` || error("dpkg-architecture failed");
chomp $arch;
return $arch;
}
diff --git a/debian/rules b/debian/rules
index 96117701..4292724e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -26,7 +26,7 @@ MAKEMANLIST=perl -e ' \
}'
# Figure out the `current debhelper version.
-VERSION=$(shell expr "`dpkg-parsechangelog 2>/dev/null |grep Version:`" : '.*Version: \(.*\)')
+VERSION=$(shell expr "`dpkg-parsechangelog |grep Version:`" : '.*Version: \(.*\)')
PERLLIBDIR=$(shell perl -MConfig -e 'print $$Config{vendorlib}')