summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Debhelper/Dh_Getopt.pm4
-rw-r--r--debian/changelog1
2 files changed, 4 insertions, 1 deletions
diff --git a/Debian/Debhelper/Dh_Getopt.pm b/Debian/Debhelper/Dh_Getopt.pm
index 214fa2df..f5364870 100644
--- a/Debian/Debhelper/Dh_Getopt.pm
+++ b/Debian/Debhelper/Dh_Getopt.pm
@@ -157,7 +157,9 @@ sub getoptions {
foreach my $opt (@test) {
# Try to parse an option, and skip it
# if it is not known.
- if (getoptions([$opt], test => 1)) {
+ if (getoptions([$opt], %params,
+ ignore_unknown_options => 0,
+ test => 1)) {
getoptions([$opt], %params);
}
}
diff --git a/debian/changelog b/debian/changelog
index 1a879f52..514301ea 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
debhelper (7.4.13) UNRELEASED; urgency=low
* dh_compress: Avoid compressing images in /usr/share/info. Closes: #567586
+ * Fix handling of -O with options specified by commands. Closes: #568081
-- Joey Hess <joeyh@debian.org> Sun, 31 Jan 2010 14:34:30 -0500