summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog5
-rwxr-xr-xdh_fixperms3
-rwxr-xr-xdh_installcatalogs8
-rwxr-xr-xdh_installdebconf7
-rwxr-xr-xdh_installemacsen3
-rwxr-xr-xdh_installinfo5
-rwxr-xr-xdh_installmenu3
-rwxr-xr-xdh_installmime3
-rwxr-xr-xdh_installmodules5
-rwxr-xr-xdh_installudev4
-rwxr-xr-xdh_installxfonts5
-rwxr-xr-xdh_scrollkeeper3
-rwxr-xr-xdh_usrlocal3
13 files changed, 35 insertions, 22 deletions
diff --git a/debian/changelog b/debian/changelog
index 21571826..7146b12d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -11,8 +11,11 @@ debhelper (5.0.43) UNRELEASED; urgency=low
too.
* dh_installudev: Fix postrm to not fail if the udev symlink is missing.
Closes: #406921
+ * dh_fixperms: Make all files in /usr/include 644, not only .h files.
+ Closes: #404785
+ * Man page improvements. Closes: #406707
- -- Joey Hess <joeyh@debian.org> Sun, 21 Jan 2007 11:42:25 -0500
+ -- Joey Hess <joeyh@debian.org> Sun, 21 Jan 2007 12:11:40 -0500
debhelper (5.0.42) unstable; urgency=low
diff --git a/dh_fixperms b/dh_fixperms
index a96b1e05..6ef0905c 100755
--- a/dh_fixperms
+++ b/dh_fixperms
@@ -76,8 +76,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
"2>/dev/null | xargs -0r chmod 644");
# ..and header files ..
- complex_doit("find $tmp/usr/include -type f",
- "-name '*.h' $find_options -print0",
+ complex_doit("find $tmp/usr/include -type f $find_options -print0",
"2>/dev/null | xargs -0r chmod 644");
# .. and perl modules.
diff --git a/dh_installcatalogs b/dh_installcatalogs
index bbe4bcf4..073cbb2b 100755
--- a/dh_installcatalogs
+++ b/dh_installcatalogs
@@ -34,11 +34,13 @@ F</etc/sgml/I<package>.cat>.
This command automatically adds maintainer script snippets for
registering and unregistering the catalogs and "supercatalogs" (unless
-B<-n> is used). A dependency on B<sgml-base> will be added to
-C<${misc:Depends}>, so be sure your package uses that variable in
-F<debian/control>. See L<dh_installdeb(1)> for an explanation of
+B<-n> is used). These snippets are inserted into the maintainer scripts
+by dh_installdeb; see L<dh_installdeb(1)> for an explanation of
Debhelper maintainer script snippets.
+A dependency on B<sgml-base> will be added to C<${misc:Depends}>, so be
+sure your package uses that variable in F<debian/control>.
+
=head1 OPTIONS
=over 4
diff --git a/dh_installdebconf b/dh_installdebconf
index c25a7795..f12c7dad 100755
--- a/dh_installdebconf
+++ b/dh_installdebconf
@@ -18,9 +18,10 @@ B<dh_installdebconf> [S<I<debhelper options>>] [B<-n>] [S<B<--> I<params>>]
dh_installdebconf is a debhelper program that is responsible for installing
files used by the debconf package into package build directories.
-It also automatically generates the postrm commands needed to
-interface with debconf. See L<dh_installdeb(1)> for an explanation of how
-that works.
+It also automatically generates the postrm commands needed to interface
+with debconf. The commands are added to the maintainer scripts by
+dh_installdeb. See L<dh_installdeb(1)> for an explanation of how that
+works.
Files named debian/package.config and debian/package.templates are
installed into the DEBIAN directory in the package build directory.
diff --git a/dh_installemacsen b/dh_installemacsen
index 80b83e69..a9227ac2 100755
--- a/dh_installemacsen
+++ b/dh_installemacsen
@@ -20,7 +20,8 @@ files used by the debian emacsen-common package into package build
directories.
It also automatically generates the postinst and prerm commands needed to
-register a package as an emacs add on package. See L<dh_installdeb(1)>
+register a package as an emacs add on package. The commands are added to
+the maintainer scripts by dh_installdeb. See L<dh_installdeb(1)>
for an explanation of how this works.
If a file named debian/package.emacsen-install exists, then it is installed
diff --git a/dh_installinfo b/dh_installinfo
index 07760cc5..e8ef2e0e 100755
--- a/dh_installinfo
+++ b/dh_installinfo
@@ -30,8 +30,9 @@ will be the first package specified by those flags.
Files named debian/package.info can list other files to be installed.
dh_installinfo will automatically generate the postinst and prerm commands
-needed to interface with install-info, updating the info . See L<dh_installdeb(1)> for an
-explanation of how this works.
+needed to interface with install-info, updating the info dir. These
+commands are inserted into the maintainer scripts by dh_installdeb.
+See L<dh_installdeb(1)> for an explanation of how this works.
=head1 OPTIONS
diff --git a/dh_installmenu b/dh_installmenu
index bf827782..e4dc3b29 100755
--- a/dh_installmenu
+++ b/dh_installmenu
@@ -19,7 +19,8 @@ dh_installmenu is a debhelper program that is responsible for installing
files used by the debian menu package into package build directories.
It also automatically generates the postinst and postrm commands needed to
-interface with the debian menu package. See L<dh_installdeb(1)> for an
+interface with the debian menu package. These commands are inserted into
+the maintainer scripts by dh_installde. See L<dh_installdeb(1)> for an
explanation of how this works.
If a file named debian/package.menu exists, then it is installed into
diff --git a/dh_installmime b/dh_installmime
index 42f2f823..a1b1b6b1 100755
--- a/dh_installmime
+++ b/dh_installmime
@@ -19,7 +19,8 @@ dh_installmime is a debhelper program that is responsible for installing
mime files into package build directories.
It also automatically generates the postinst and postrm commands needed to
-interface with the debian mime-support and shared-mime-info packages. See
+interface with the debian mime-support and shared-mime-info packages. These
+commands are inserted into the maintainer scripts by dh_installdeb. See
L<dh_installdeb(1)> for an explanation of how this works.
If files named debian/package.mime or debian/package.sharedmimeinfo exist, then
diff --git a/dh_installmodules b/dh_installmodules
index 6b996a58..99dcc31a 100755
--- a/dh_installmodules
+++ b/dh_installmodules
@@ -28,8 +28,9 @@ module-init-tools's version of modprobe.
Kernel modules are searched for in the package build directory and if
found, postinst and postrm commands are automatically generated to
-run depmod and register the modules when the package is installed. See
-L<dh_installdeb(1)> for an explanation of how this works.
+run depmod and register the modules when the package is installed.
+These commands are inserted into the maintainer scripts by dh_installdeb.
+See L<dh_installdeb(1)> for an explanation of how this works.
=head1 OPTIONS
diff --git a/dh_installudev b/dh_installudev
index 26692ece..1e8ccea8 100755
--- a/dh_installudev
+++ b/dh_installudev
@@ -4,7 +4,6 @@
dh_installudev - install udev rules files
-
=cut
use strict;
@@ -25,7 +24,8 @@ etc/udev/package.rules in the package build directory.
Then postinst and postrm commands are automatically generated to enable
the rules file when the package is first installed, by creating a symlink
-to it in the /etc/udev/rules.d/ directory. See L<dh_installdeb(1)> for an
+to it in the /etc/udev/rules.d/ directory. These commands are inserted into
+the maintainer scripts by dh_installdeb. See L<dh_installdeb(1)> for an
explanation of how this works.
=head1 OPTIONS
diff --git a/dh_installxfonts b/dh_installxfonts
index d1ced88e..b7921a2b 100755
--- a/dh_installxfonts
+++ b/dh_installxfonts
@@ -30,8 +30,9 @@ update-fonts-* commands are available. (This program adds that dependency to
${misc:Depends}.)
This program automatically generates the postinst and postrm commands needed
-to register X fonts. See L<dh_installdeb(1)> for an explanation of how this
-works.
+to register X fonts. These commands are inserted into the maintainer
+scripts by dh_installdeb. See L<dh_installdeb(1)> for an explanation of how
+this works.
=head1 NOTES
diff --git a/dh_scrollkeeper b/dh_scrollkeeper
index 3cfd414f..1c792492 100755
--- a/dh_scrollkeeper
+++ b/dh_scrollkeeper
@@ -20,7 +20,8 @@ registering OMF files that it finds in package build trees with
ScrollKeeper.
This command automatically adds maintainer script snippets for registering
-and unregistering files with ScrollKeeper (unless B<-n> is used). See
+and unregistering files with ScrollKeeper (unless B<-n> is used). These
+snippets are inserted into the maintainer scripts by dh_installdeb. See
L<dh_installdeb(1)> for an explanation of Debhelper maintainer script
snippets.
diff --git a/dh_usrlocal b/dh_usrlocal
index f13c58fa..a82e21ca 100755
--- a/dh_usrlocal
+++ b/dh_usrlocal
@@ -24,7 +24,8 @@ that will provide a subdirectory in /usr/local when installed.
It finds subdirectories of usr/local in the package build directory, and
removes them, replacing them with maintainer script snippets (unless B<-n>
is used) to create the directories at install time, and remove them when
-the package is removed, in a manner compliant with Debian policy. See
+the package is removed, in a manner compliant with Debian policy. These
+snippets are inserted into the maintainer scripts by dh_installdeb. See
L<dh_installdeb(1)> for an explanation of Debhelper maintainer script
snippets.