summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rwxr-xr-xdh_makeshlibs2
2 files changed, 7 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index dfe4e492..1688999a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (7.2.4) UNRELEASED; urgency=low
+
+ * dh_makeshlibs: Fix --add-udeb, for real. Closes: #518706
+
+ -- Joey Hess <joeyh@debian.org> Sun, 08 Mar 2009 13:14:02 -0400
+
debhelper (7.2.3) unstable; urgency=low
* dh_installmenus: Now that a triggers capable menu and dpkg are in
diff --git a/dh_makeshlibs b/dh_makeshlibs
index 1ece98de..776e66f0 100755
--- a/dh_makeshlibs
+++ b/dh_makeshlibs
@@ -108,7 +108,7 @@ init(options => {
"m=s", => \$dh{M_PARAMS},
"major=s" => \$dh{M_PARAMS},
"version-info:s" => \$dh{V_FLAG},
- "add-udeb" => \$dh{SHLIBS_UDEB},
+ "add-udeb=s" => \$dh{SHLIBS_UDEB},
});
foreach my $package (@{$dh{DOPACKAGES}}) {