summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog11
-rw-r--r--debian/control4
-rwxr-xr-xdh_installman2
3 files changed, 14 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 2ccd1ef9..81b37007 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,14 @@
+debhelper (4.1.16) unstable; urgency=low
+
+ * Depend on po-debconf, and I hope I can drop the debconf-utils dep soon.
+ Closes: #163569
+ * Removed debconf-utils build-dep. Have no idea why that was there.
+ * dh_installman: Don't use extended section as section name for translated
+ man pages, use only the numeric section as is done for regular man pages.
+ Closes: #163534
+
+ -- Joey Hess <joeyh@debian.org> Mon, 7 Oct 2002 11:49:37 -0400
+
debhelper (4.1.15) unstable; urgency=low
* dh_compress: Exclude .css files, to prevent broken links from html files,
diff --git a/debian/control b/debian/control
index 683756d6..5825a227 100644
--- a/debian/control
+++ b/debian/control
@@ -2,12 +2,12 @@ Source: debhelper
Section: devel
Priority: optional
Maintainer: Joey Hess <joeyh@debian.org>
-Build-Depends-Indep: perl (>= 5.6.1), coreutils | fileutils (>= 4.0-2.1), file (>= 3.23-1), debconf-utils (>= 1.1.1), dpkg-dev (>= 1.9.0)
+Build-Depends-Indep: perl (>= 5.6.1), coreutils | fileutils (>= 4.0-2.1), file (>= 3.23-1), dpkg-dev (>= 1.9.0)
Standards-Version: 3.5.7.0
Package: debhelper
Architecture: all
-Depends: ${perl:Depends}, ${misc:Depends}, coreutils | fileutils (>= 4.0-2.1), file (>= 3.23-1), dpkg-dev (>= 1.7.0), html2text, debconf-utils (>= 1.1.1), binutils
+Depends: ${perl:Depends}, ${misc:Depends}, coreutils | fileutils (>= 4.0-2.1), file (>= 3.23-1), dpkg-dev (>= 1.7.0), html2text, debconf-utils (>= 1.1.1), binutils, po-debconf
Suggests: dh-make
Description: helper programs for debian/rules
A collection of programs that can be used in a debian/rules file to
diff --git a/dh_installman b/dh_installman
index 402f4a94..3da08ccb 100755
--- a/dh_installman
+++ b/dh_installman
@@ -141,7 +141,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# redirect to appropriate directory, stripping the code.
my ($langcode)=$basename=~m/.*\.([a-z][a-z](?:_[A-Z][A-Z])?)\.(?:[1-9]|man)/;
if (defined $langcode && $langcode ne '') {
- $destdir="$tmp/usr/share/man/$langcode/man$section/";
+ $destdir="$tmp/usr/share/man/$langcode/man$realsection/";
# Strip the language code from the instname.
$instname=~s/\.$langcode$//;
}