summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog13
-rw-r--r--debian/control2
-rwxr-xr-xdh_movefiles8
-rw-r--r--dh_movefiles.14
-rwxr-xr-xdh_shlibdeps4
-rw-r--r--dh_shlibdeps.110
6 files changed, 17 insertions, 24 deletions
diff --git a/debian/changelog b/debian/changelog
index 403831eb..39380a1e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,16 @@
+debhelper (2.1.21) unstable; urgency=low
+
+ * dh_movefiles: no longer does the symlink ordering hack, as
+ this is supported by dpkg itself now. Added a dependancy on
+ dpkg-dev >= 1.7.0 to make sure this doesn't break anything.
+ * While I'm updating for dpkg 1.7.0, I removed the -ldirectory hack
+ from dh_shlibdeps; dpkg-shlibdeps has its own much more brutal hack to
+ make this work. The switch is ignored now for backwards compatability.
+ * dh_suidregister will be deprecated soon -- dpkg-statoverride is a
+ much better way.
+
+ -- Joey Hess <joeyh@debian.org> Mon, 6 Nov 2000 15:14:49 -0800
+
debhelper (2.1.20) unstable; urgency=low
* dh_suidregister: do not unregister on purge, since it will have already
diff --git a/debian/control b/debian/control
index 42830ee4..8319f077 100644
--- a/debian/control
+++ b/debian/control
@@ -7,7 +7,7 @@ Standards-Version: 3.2.1.0
Package: debhelper
Architecture: all
-Depends: perl5 | perl (>= 5.004), fileutils (>= 4.0-2.1), file (>= 3.23-1)
+Depends: perl5 | perl (>= 5.004), fileutils (>= 4.0-2.1), file (>= 3.23-1), dpkg-dev (>= 1.7.0)
Suggests: dh-make, lynx
Description: helper programs for debian/rules
A collection of programs that can be used in a debian/rules file to
diff --git a/dh_movefiles b/dh_movefiles
index 60e16f12..f2ea1231 100755
--- a/dh_movefiles
+++ b/dh_movefiles
@@ -61,13 +61,7 @@ foreach $PACKAGE (@{$dh{DOPACKAGES}}) {
$file=$_;
$ret=1 if (! -e $file && ! -l $file);
$file=~s:^\Q$sourcedir\E/+::;
- complex_doit("(cd $sourcedir >/dev/null ; find $file ! -type d -and ! -type l -print || true) >> debian/movelist");
- }
- foreach (@filelist) {
- $file=$_;
- $ret=1 if (! -e $file && ! -l $file);
- $file=~s:^\Q$sourcedir\E/+::;
- complex_doit("(cd $sourcedir >/dev/null ; find $file ! -type d -and -type l -print || true) >> debian/movelist");
+ complex_doit("(cd $sourcedir >/dev/null ; find $file ! -type d -print || true) >> debian/movelist");
}
complex_doit("(cd $sourcedir >/dev/null ; tar --create --remove-files --files-from=../movelist --file -) | (cd $TMP >/dev/null ;tar xpf -)");
doit("rm","-f","debian/movelist");
diff --git a/dh_movefiles.1 b/dh_movefiles.1
index a2298605..a96086d0 100644
--- a/dh_movefiles.1
+++ b/dh_movefiles.1
@@ -16,10 +16,6 @@ also list directory names, and the whole directory will be moved. You can
even use wildcards if you like. If you prefer, you can list the files to
move on the command line and this will apply to the first package
dh_movefiles is told to act on.
-.P
-The files will be moved in a special order: first all normal files, then all
-symlinks. This is done because it tends to be a good thing to have symlinks
-last in debian packages, particularly in shared library packages.
.SH OPTIONS
.TP
.B debhelper options
diff --git a/dh_shlibdeps b/dh_shlibdeps
index 237d92db..0456a2dc 100755
--- a/dh_shlibdeps
+++ b/dh_shlibdeps
@@ -29,10 +29,6 @@ foreach $PACKAGE (@{$dh{DOPACKAGES}}) {
}
if (@filelist) {
- if ($dh{L_PARAMS}) {
- $ENV{'LD_LIBRARY_PATH'}=$dh{L_PARAMS};
- verbose_print("LD_LIBRARY_PATH=$dh{L_PARAMS} \\");
- }
doit("dpkg-shlibdeps","-Tdebian/${EXT}substvars",@{$dh{U_PARAMS}},'-dDepends',@filelist);
}
}
diff --git a/dh_shlibdeps.1 b/dh_shlibdeps.1
index d09967a9..6ced958c 100644
--- a/dh_shlibdeps.1
+++ b/dh_shlibdeps.1
@@ -3,7 +3,7 @@
dh_shlibdeps \- calculate shared library dependancies
.SH SYNOPSIS
.B dh_shlibdeps
-.I "[debhelper options] [-ldirectory] [-uparams] [-Xitem] [-- params]"
+.I "[debhelper options] [-uparams] [-Xitem] [-- params]"
.SH "DESCRIPTION"
dh_shlibdeps is a debhelper program that is responsible for calculating
shared library dependancies for packages.
@@ -32,13 +32,7 @@ This may be useful in some situations, but use it with caution. This option
may be used more than once to exclude more than one thing.
.TP
.B \-ldirectory
-Before
-.BR dpkg-shlibdeps (1)
-is run, LD_LIBRARY_PATH will be set to the specified directory.
-This is useful for multi-binary packages where a library
-is built in one package and another package contains binaries linked
-against said library. Note that the paths used must be absolute or
-dpkg-shlibdeps will become confused.
+This option is ignored, for backwards compatability.
.SH ENVIRONMENT
See
.BR debhelper (1)