summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_shlibdeps5
-rw-r--r--dh_shlibdeps.14
3 files changed, 14 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index c55dc52d..4d6f2134 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (2.2.19) unstable; urgency=low
+
+ * dh_shlibdeps -l can handle relative paths now. Patch from Colin Watson
+ <cjw44@flatline.org.uk>, Closes: #84408
+
+ -- Joey Hess <joeyh@debian.org> Thu, 1 Feb 2001 13:35:39 -0800
+
debhelper (2.2.18) unstable; urgency=medium
* Added a suggests to debconf-utils, Closes: #83643
diff --git a/dh_shlibdeps b/dh_shlibdeps
index 237d92db..a0666b93 100755
--- a/dh_shlibdeps
+++ b/dh_shlibdeps
@@ -2,6 +2,7 @@
#
# Find dependancies. Simple dpkg-shlibdeps wrapper.
+use Cwd;
use Debian::Debhelper::Dh_Lib;
init();
@@ -30,6 +31,10 @@ foreach $PACKAGE (@{$dh{DOPACKAGES}}) {
if (@filelist) {
if ($dh{L_PARAMS}) {
+ # Force the path absolute.
+ unless ($dh{L_PARAMS}=~m:^/:) {
+ $dh{L_PARAMS}=getcwd()."/$dh{L_PARAMS}";
+ }
$ENV{'LD_LIBRARY_PATH'}=$dh{L_PARAMS};
verbose_print("LD_LIBRARY_PATH=$dh{L_PARAMS} \\");
}
diff --git a/dh_shlibdeps.1 b/dh_shlibdeps.1
index d09967a9..14e56b02 100644
--- a/dh_shlibdeps.1
+++ b/dh_shlibdeps.1
@@ -37,8 +37,8 @@ Before
is run, LD_LIBRARY_PATH will be set to the specified directory.
This is useful for multi-binary packages where a library
is built in one package and another package contains binaries linked
-against said library. Note that the paths used must be absolute or
-dpkg-shlibdeps will become confused.
+against said library. Relative paths will be made absolute for the
+benefit of dpkg-shlibdeps.
.SH ENVIRONMENT
See
.BR debhelper (1)