summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_perl2
2 files changed, 8 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 709e49c3..4abd71ee 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (4.1.4) unstable; urgency=low
+
+ * Patch from Andrew Suffield to make dh_perl understand #!/usr/bin/env perl
+ Closes: #156243
+
+ -- Joey Hess <joeyh@debian.org> Sat, 17 Aug 2002 23:05:45 -0400
+
debhelper (4.1.3) unstable; urgency=low
* dh_installinit: Always start daemon on upgraded even if
diff --git a/dh_perl b/dh_perl
index a40c6fd5..e9a001d9 100755
--- a/dh_perl
+++ b/dh_perl
@@ -106,7 +106,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
return unless -f and (-x or /\.pl$/);
local *F;
return unless open F, $_;
- if (read F, local $_, 32 and m%^#!\s*/usr/bin/perl\s%) {
+ if (read F, local $_, 32 and m%^#!\s*(/usr/bin/perl|/usr/bin/env\s+perl)\s%) {
$deps |= PROGRAM;
}
close F;