summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rw-r--r--debian/control2
-rwxr-xr-xdh_installman5
3 files changed, 10 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 1e32a1cf..d634f5a6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (8.9.7) UNRELEASED; urgency=low
+
+ * debhelper no longer build-depends on man-db, to ease bootstrapping.
+
+ -- Joey Hess <joeyh@debian.org> Mon, 29 Aug 2011 20:18:01 -0400
+
debhelper (8.9.6) unstable; urgency=low
* dh_installlogcheck: Add support for --name. Closes: #639020
diff --git a/debian/control b/debian/control
index beea40f7..ec55b5c2 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: debhelper
Section: devel
Priority: optional
Maintainer: Joey Hess <joeyh@debian.org>
-Build-Depends: po4a (>= 0.24), man-db (>= 2.5.1), file (>= 3.23), perl-base (>= 5.10)
+Build-Depends: po4a (>= 0.24), file (>= 3.23), perl-base (>= 5.10)
Standards-Version: 3.9.2
Vcs-Git: git://git.debian.org/git/debhelper/debhelper.git
Vcs-Browser: http://git.debian.org/?p=debhelper/debhelper.git;a=summary
diff --git a/dh_installman b/dh_installman
index fb7c8eb4..e1182815 100755
--- a/dh_installman
+++ b/dh_installman
@@ -197,8 +197,9 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
# Now utf-8 conversion.
- foreach my $dir (qw{usr/share/man}) {
- if (-e "$tmp/$dir") {
+ if (defined `man --version`) {
+ foreach my $dir (qw{usr/share/man}) {
+ next unless -e "$tmp/$dir";
find(sub {
return if ! -f $_ || -l $_;
my ($tmp, $orig)=($_.".new", $_);