summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdh_installdocs3
2 files changed, 5 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 012d7030..4b756b8d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -18,6 +18,8 @@ debhelper (7.4.4) UNRELEASED; urgency=low
Closes: #548382
* Adjust code to add deprecation warning for compatability level 4.
(Man page already said it was deprecated.) Closes: #555899
+ * dh_installdocs: Warn if a doc-base file cannot be parsed to find a
+ document id. Closes: #555677
-- Joey Hess <joeyh@debian.org> Wed, 28 Oct 2009 18:10:45 -0400
diff --git a/dh_installdocs b/dh_installdocs
index d8ebe62e..5f4abfdb 100755
--- a/dh_installdocs
+++ b/dh_installdocs
@@ -280,6 +280,9 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
last;
}
}
+ if (! exists $doc_ids{$fn}) {
+ warning("Could not parse $fn for doc-base Document id; skipping");
+ }
close IN;
}
closedir(DEB);