summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_shlibdeps38
2 files changed, 27 insertions, 18 deletions
diff --git a/debian/changelog b/debian/changelog
index 70175695..e0a61241 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (3.0.25) unstable; urgency=low
+
+ * dh_makeshlins: append to LD_LIBRARY_PATH at start, not each time
+ through loop. Closes: #98598
+
+ -- Joey Hess <joeyh@debian.org> Thu, 24 May 2001 14:16:50 -0400
+
debhelper (3.0.24) unstable; urgency=low
* Missing semi-colon.
diff --git a/dh_shlibdeps b/dh_shlibdeps
index 274aeeda..744aa5bf 100755
--- a/dh_shlibdeps
+++ b/dh_shlibdeps
@@ -55,6 +55,26 @@ dpkg-shlibdeps.
init();
+# Add directory to library search path.
+if ($dh{L_PARAMS}) {
+ my @paths=();
+ # Add to existing paths, if set.
+ push @paths, $ENV{'LD_LIBRARY_PATH'}
+ if exists $ENV{'LD_LIBRARY_PATH'};
+ foreach (split(/:/, $dh{L_PARAMS})) {
+ # Force the path absolute.
+ if (m:^/:) {
+ push @paths, $_;
+ }
+ else {
+ push @paths, getcwd()."/$_";
+ }
+ }
+ $dh{L_PARAMS}=join(':', @paths);
+ $ENV{'LD_LIBRARY_PATH'}=$dh{L_PARAMS};
+ verbose_print("LD_LIBRARY_PATH=$dh{L_PARAMS}");
+}
+
foreach my $package (@{$dh{DOPACKAGES}}) {
my $tmp=tmpdir($package);
my $ext=pkgext($package);
@@ -77,24 +97,6 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
if (@filelist) {
- if ($dh{L_PARAMS}) {
- my @paths=();
- # Add to existing paths, if set.
- push @paths, $ENV{'LD_LIBRARY_PATH'}
- if exists $ENV{'LD_LIBRARY_PATH'};
- foreach (split(/:/, $dh{L_PARAMS})) {
- # Force the path absolute.
- if (m:^/:) {
- push @paths, $_;
- }
- else {
- push @paths, getcwd()."/$_";
- }
- }
- $dh{L_PARAMS}=join(':', @paths);
- $ENV{'LD_LIBRARY_PATH'}=$dh{L_PARAMS};
- verbose_print("LD_LIBRARY_PATH=$dh{L_PARAMS} \\");
- }
doit("dpkg-shlibdeps","-Tdebian/${ext}substvars",@{$dh{U_PARAMS}},'-dDepends',@filelist);
}
}