summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--autoscripts/prerm-python8
-rw-r--r--debian/changelog8
-rwxr-xr-xdh_install2
3 files changed, 12 insertions, 6 deletions
diff --git a/autoscripts/prerm-python b/autoscripts/prerm-python
index 0dc12731..e6e779f8 100644
--- a/autoscripts/prerm-python
+++ b/autoscripts/prerm-python
@@ -1,5 +1,3 @@
-if [ "$1" = remove ]; then
- dpkg -L #PACKAGE# |
- awk '$0~/\.py$/ {print $0"c\n" $0"o"}' |
- xargs rm -f >&2
-fi
+dpkg -L #PACKAGE# |
+ awk '$0~/\.py$/ {print $0"c\n" $0"o"}' |
+ xargs rm -f >&2
diff --git a/debian/changelog b/debian/changelog
index 99fcd61c..0b33ce8f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (4.1.58) unstable; urgency=low
+
+ * Typo, Closes: #203907
+ * dh_python: clan compiled files on downgrade, upgrade, not only
+ removal. Closes: #204286
+
+ -- Joey Hess <joeyh@debian.org> Thu, 7 Aug 2003 15:47:06 -0400
+
debhelper (4.1.57) unstable; urgency=low
* dh_install: Add LIMITATIONS section and other changes to clarify
diff --git a/dh_install b/dh_install
index 0d807d6f..57851678 100755
--- a/dh_install
+++ b/dh_install
@@ -225,7 +225,7 @@ If you want a libfoo-dev package too, debian/libfoo-dev.install might contain:
usr/lib/libfoo*.so
usr/share/man/man3
-=head1 LIMITIATIONS
+=head1 LIMITATIONS
dh_install cannot rename files or directories, it can only install them
with the names they already have into wherever you want in the package