summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rwxr-xr-xdh_installman6
-rwxr-xr-xdh_movefiles4
3 files changed, 14 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 67991443..964de4b4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (3.4.9) unstable; urgency=low
+
+ * dh_movefiles: Allow for deeper --sourcedir. Closes: #131363
+
+ -- Joey Hess <joeyh@debian.org> Wed, 20 Feb 2002 16:37:43 -0500
+
debhelper (3.4.8) unstable; urgency=low
* Thanks to Benjamin Drieu <benj@debian.org>, dh_installdocs -X now works.
diff --git a/dh_installman b/dh_installman
index e558f266..30fde7e2 100755
--- a/dh_installman
+++ b/dh_installman
@@ -27,7 +27,11 @@ If dh_installman seems to install a man page into the wrong section or with
the wrong extension, this is because the man page has the wrong section
listed in its .TH line. Edit the man page and correct the section, and
dh_installman will follow suit. See to L<man(7)> for details about the .TH
-section.
+section. If dh_installman seems to install a man page into a directory
+like /usr/share/man/pl/man1/, that is because your program has a
+name like "foo.pl", and dh_installman assumes that means it is translated
+into Polish. There is currently no support for resolving this ambiguity;
+programs in debian should proably not have extensions like that anyway.
Any man page filenames specified as parameters will be installed into the
first package dh_installman is told to act on. By default, this is the
diff --git a/dh_movefiles b/dh_movefiles
index cef89101..4cde0887 100755
--- a/dh_movefiles
+++ b/dh_movefiles
@@ -125,7 +125,9 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
$file=~s:^\Q$sourcedir\E/+::;
complex_doit("(cd $sourcedir >/dev/null ; find $file ! -type d -print || true) >> debian/movelist");
}
- complex_doit("(cd $sourcedir >/dev/null ; tar --create --remove-files --files-from=../movelist --file -) | (cd $tmp >/dev/null ;tar xpf -)");
+ my $pwd=`pwd`;
+ chomp $pwd;
+ complex_doit("(cd $sourcedir >/dev/null ; tar --create --remove-files --files-from=$pwd/movelist --file -) | (cd $tmp >/dev/null ;tar xpf -)");
doit("rm","-f","debian/movelist");
}
}