summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog11
-rwxr-xr-xdh_auto_install7
2 files changed, 15 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index a6c21e27..00d33565 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,14 @@
+debhelper (7.0.13) unstable; urgency=low
+
+ * dh_auto_install: Rather than looking at the number of binary packages
+ being acted on, look at the total number of binary packages in the
+ source package when deciding whether to install to debian/package or
+ debian/tmp. This avoids inconsistencies when building mixed arch all+any
+ packages using the binary-indep and binary-arch targets.
+ Closes: #487938
+
+ -- Joey Hess <joeyh@debian.org> Wed, 25 Jun 2008 12:27:02 -0400
+
debhelper (7.0.12) unstable; urgency=medium
* Correct docs about dh_install and debian/tmp in v7 mode. It first looks in
diff --git a/dh_auto_install b/dh_auto_install
index 78fba170..2c8c7f6b 100755
--- a/dh_auto_install
+++ b/dh_auto_install
@@ -22,8 +22,8 @@ then this is done by running make (or MAKE, if the environment variable is
set). If there is a setup.py or Build.PL, it is used.
The files are installed into debian/<package>/ if there is only one binary
-package to act on. In the multiple binary package case, the files are
-instead installed into debian/tmp/, and should be moved from there to the
+package. In the multiple binary package case, the files are instead
+installed into debian/tmp/, and should be moved from there to the
appropriate package build directory using L<dh_install(1)> or
L<dh_movefiles(1)>.
@@ -51,7 +51,8 @@ or override the any standard parameters that dh_auto_clean passes.
init();
my $destdir;
-if (@{$dh{DOPACKAGES}} > 1) {
+my @allpackages=getpackages();
+if (@allpackages > 1) {
$destdir="debian/tmp";
}
else {